summaryrefslogtreecommitdiffstats
path: root/tests/run-make/jobserver-error
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/jobserver-error')
-rw-r--r--tests/run-make/jobserver-error/Makefile9
-rw-r--r--tests/run-make/jobserver-error/jobserver.stderr4
2 files changed, 13 insertions, 0 deletions
diff --git a/tests/run-make/jobserver-error/Makefile b/tests/run-make/jobserver-error/Makefile
new file mode 100644
index 000000000..4a1699cc7
--- /dev/null
+++ b/tests/run-make/jobserver-error/Makefile
@@ -0,0 +1,9 @@
+include ../tools.mk
+
+# only-linux
+# ignore-test: This test randomly fails, see https://github.com/rust-lang/rust/issues/110321
+
+# Test compiler behavior in case: `jobserver-auth` points to correct pipe which is not jobserver.
+
+all:
+ bash -c 'echo "fn main() {}" | MAKEFLAGS="--jobserver-auth=3,3" $(RUSTC) - 3</dev/null' 2>&1 | diff jobserver.stderr -
diff --git a/tests/run-make/jobserver-error/jobserver.stderr b/tests/run-make/jobserver-error/jobserver.stderr
new file mode 100644
index 000000000..d18e15a26
--- /dev/null
+++ b/tests/run-make/jobserver-error/jobserver.stderr
@@ -0,0 +1,4 @@
+error: failed to acquire jobserver token: early EOF on jobserver pipe
+
+error: aborting due to previous error
+