summaryrefslogtreecommitdiffstats
path: root/tests/run-make/llvm-outputs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/llvm-outputs/Makefile')
-rw-r--r--tests/run-make/llvm-outputs/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/run-make/llvm-outputs/Makefile b/tests/run-make/llvm-outputs/Makefile
new file mode 100644
index 000000000..a3f25eba0
--- /dev/null
+++ b/tests/run-make/llvm-outputs/Makefile
@@ -0,0 +1,5 @@
+include ../../run-make-fulldeps/tools.mk
+
+all:
+ echo 'fn main() {}' | $(BARE_RUSTC) - --out-dir=$(TMPDIR)/random_directory_that_does_not_exist_ir/ --emit=llvm-ir
+ echo 'fn main() {}' | $(BARE_RUSTC) - --out-dir=$(TMPDIR)/random_directory_that_does_not_exist_bc/ --emit=llvm-bc