summaryrefslogtreecommitdiffstats
path: root/tests/run-make/longjmp-across-rust
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/longjmp-across-rust')
-rw-r--r--tests/run-make/longjmp-across-rust/Makefile6
-rw-r--r--tests/run-make/longjmp-across-rust/foo.c18
-rw-r--r--tests/run-make/longjmp-across-rust/main.rs29
3 files changed, 53 insertions, 0 deletions
diff --git a/tests/run-make/longjmp-across-rust/Makefile b/tests/run-make/longjmp-across-rust/Makefile
new file mode 100644
index 000000000..5fd2d4f85
--- /dev/null
+++ b/tests/run-make/longjmp-across-rust/Makefile
@@ -0,0 +1,6 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all: $(call NATIVE_STATICLIB,foo)
+ $(RUSTC) main.rs
+ $(call RUN,main)
diff --git a/tests/run-make/longjmp-across-rust/foo.c b/tests/run-make/longjmp-across-rust/foo.c
new file mode 100644
index 000000000..bd71cc4d7
--- /dev/null
+++ b/tests/run-make/longjmp-across-rust/foo.c
@@ -0,0 +1,18 @@
+#include <assert.h>
+#include <setjmp.h>
+
+static jmp_buf ENV;
+
+extern void test_middle();
+
+void test_start(void(*f)()) {
+ if (setjmp(ENV) != 0)
+ return;
+ f();
+ assert(0);
+}
+
+void test_end() {
+ longjmp(ENV, 1);
+ assert(0);
+}
diff --git a/tests/run-make/longjmp-across-rust/main.rs b/tests/run-make/longjmp-across-rust/main.rs
new file mode 100644
index 000000000..cc1d5b126
--- /dev/null
+++ b/tests/run-make/longjmp-across-rust/main.rs
@@ -0,0 +1,29 @@
+#[link(name = "foo", kind = "static")]
+extern "C" {
+ fn test_start(f: extern "C" fn());
+ fn test_end();
+}
+
+fn main() {
+ unsafe {
+ test_start(test_middle);
+ }
+}
+
+struct A;
+
+impl Drop for A {
+ fn drop(&mut self) {}
+}
+
+extern "C" fn test_middle() {
+ let _a = A;
+ foo();
+}
+
+fn foo() {
+ let _a = A;
+ unsafe {
+ test_end();
+ }
+}