summaryrefslogtreecommitdiffstats
path: root/tests/run-make/lto-smoke-c
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/lto-smoke-c')
-rw-r--r--tests/run-make/lto-smoke-c/Makefile12
-rw-r--r--tests/run-make/lto-smoke-c/bar.c6
-rw-r--r--tests/run-make/lto-smoke-c/foo.rs4
3 files changed, 22 insertions, 0 deletions
diff --git a/tests/run-make/lto-smoke-c/Makefile b/tests/run-make/lto-smoke-c/Makefile
new file mode 100644
index 000000000..f1ba3d95d
--- /dev/null
+++ b/tests/run-make/lto-smoke-c/Makefile
@@ -0,0 +1,12 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# Apparently older versions of GCC segfault if -g is passed...
+CC := $(CC:-g=)
+
+all:
+ $(RUSTC) foo.rs -C lto
+ $(CC) bar.c $(call STATICLIB,foo) \
+ $(call OUT_EXE,bar) \
+ $(EXTRACFLAGS) $(EXTRACXXFLAGS)
+ $(call RUN,bar)
diff --git a/tests/run-make/lto-smoke-c/bar.c b/tests/run-make/lto-smoke-c/bar.c
new file mode 100644
index 000000000..bb4036b06
--- /dev/null
+++ b/tests/run-make/lto-smoke-c/bar.c
@@ -0,0 +1,6 @@
+void foo();
+
+int main() {
+ foo();
+ return 0;
+}
diff --git a/tests/run-make/lto-smoke-c/foo.rs b/tests/run-make/lto-smoke-c/foo.rs
new file mode 100644
index 000000000..2e59432cd
--- /dev/null
+++ b/tests/run-make/lto-smoke-c/foo.rs
@@ -0,0 +1,4 @@
+#![crate_type = "staticlib"]
+
+#[no_mangle]
+pub extern "C" fn foo() {}