summaryrefslogtreecommitdiffstats
path: root/tests/run-make/min-global-align
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/min-global-align')
-rw-r--r--tests/run-make/min-global-align/Makefile22
-rw-r--r--tests/run-make/min-global-align/min_global_align.rs32
2 files changed, 54 insertions, 0 deletions
diff --git a/tests/run-make/min-global-align/Makefile b/tests/run-make/min-global-align/Makefile
new file mode 100644
index 000000000..82f38749e
--- /dev/null
+++ b/tests/run-make/min-global-align/Makefile
@@ -0,0 +1,22 @@
+include ../tools.mk
+
+# only-linux
+
+# This tests ensure that global variables respect the target minimum alignment.
+# The three bools `STATIC_BOOL`, `STATIC_MUT_BOOL`, and `CONST_BOOL` all have
+# type-alignment of 1, but some targets require greater global alignment.
+
+SRC = min_global_align.rs
+LL = $(TMPDIR)/min_global_align.ll
+
+all:
+# Most targets are happy with default alignment -- take i686 for example.
+ifeq ($(filter x86,$(LLVM_COMPONENTS)),x86)
+ $(RUSTC) --target=i686-unknown-linux-gnu --emit=llvm-ir $(SRC)
+ [ "$$(grep -c 'align 1' "$(LL)")" -eq "3" ]
+endif
+# SystemZ requires even alignment for PC-relative addressing.
+ifeq ($(filter systemz,$(LLVM_COMPONENTS)),systemz)
+ $(RUSTC) --target=s390x-unknown-linux-gnu --emit=llvm-ir $(SRC)
+ [ "$$(grep -c 'align 2' "$(LL)")" -eq "3" ]
+endif
diff --git a/tests/run-make/min-global-align/min_global_align.rs b/tests/run-make/min-global-align/min_global_align.rs
new file mode 100644
index 000000000..135792e93
--- /dev/null
+++ b/tests/run-make/min-global-align/min_global_align.rs
@@ -0,0 +1,32 @@
+#![feature(no_core, lang_items)]
+#![crate_type = "rlib"]
+#![no_core]
+
+pub static STATIC_BOOL: bool = true;
+
+pub static mut STATIC_MUT_BOOL: bool = true;
+
+const CONST_BOOL: bool = true;
+pub static CONST_BOOL_REF: &'static bool = &CONST_BOOL;
+
+#[lang = "sized"]
+trait Sized {}
+
+#[lang = "copy"]
+trait Copy {}
+impl Copy for bool {}
+impl Copy for &bool {}
+
+#[lang = "freeze"]
+trait Freeze {}
+
+// No `UnsafeCell`, so everything is `Freeze`.
+impl<T: ?Sized> Freeze for T {}
+
+#[lang = "sync"]
+trait Sync {}
+impl Sync for bool {}
+impl Sync for &'static bool {}
+
+#[lang = "drop_in_place"]
+pub unsafe fn drop_in_place<T: ?Sized>(_: *mut T) {}