summaryrefslogtreecommitdiffstats
path: root/tests/run-make/mismatching-target-triples
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/mismatching-target-triples')
-rw-r--r--tests/run-make/mismatching-target-triples/Makefile11
-rw-r--r--tests/run-make/mismatching-target-triples/bar.rs3
-rw-r--r--tests/run-make/mismatching-target-triples/foo.rs3
3 files changed, 17 insertions, 0 deletions
diff --git a/tests/run-make/mismatching-target-triples/Makefile b/tests/run-make/mismatching-target-triples/Makefile
new file mode 100644
index 000000000..409388e04
--- /dev/null
+++ b/tests/run-make/mismatching-target-triples/Makefile
@@ -0,0 +1,11 @@
+include ../tools.mk
+
+# Issue #10814
+#
+# these are no_std to avoid having to have the standard library or any
+# linkers/assemblers for the relevant platform
+
+all:
+ $(RUSTC) foo.rs --target=i686-unknown-linux-gnu
+ $(RUSTC) bar.rs --target=x86_64-unknown-linux-gnu 2>&1 \
+ | $(CGREP) 'couldn'"'"'t find crate `foo` with expected target triple x86_64-unknown-linux-gnu'
diff --git a/tests/run-make/mismatching-target-triples/bar.rs b/tests/run-make/mismatching-target-triples/bar.rs
new file mode 100644
index 000000000..b2c2fc1c4
--- /dev/null
+++ b/tests/run-make/mismatching-target-triples/bar.rs
@@ -0,0 +1,3 @@
+#![feature(no_core)]
+#![no_core]
+extern crate foo;
diff --git a/tests/run-make/mismatching-target-triples/foo.rs b/tests/run-make/mismatching-target-triples/foo.rs
new file mode 100644
index 000000000..6fa054914
--- /dev/null
+++ b/tests/run-make/mismatching-target-triples/foo.rs
@@ -0,0 +1,3 @@
+#![feature(no_core)]
+#![no_core]
+#![crate_type = "lib"]