summaryrefslogtreecommitdiffstats
path: root/tests/run-make/mixing-libs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tests/run-make/mixing-libs/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/tests/run-make/mixing-libs/Makefile b/tests/run-make/mixing-libs/Makefile
index e8262b284..459db0dfd 100644
--- a/tests/run-make/mixing-libs/Makefile
+++ b/tests/run-make/mixing-libs/Makefile
@@ -2,9 +2,7 @@
include ../tools.mk
all:
- $(RUSTC) rlib.rs
- $(RUSTC) dylib.rs
- $(RUSTC) rlib.rs --crate-type=dylib
- $(RUSTC) dylib.rs
- $(call REMOVE_DYLIBS,rlib)
+ $(RUSTC) rlib.rs --crate-type=rlib --crate-type=dylib
+ $(RUSTC) dylib.rs # no -Cprefer-dynamic so statically linking librlib.rlib
+ $(call REMOVE_DYLIBS,rlib) # remove librlib.so to test that prog.rs doesn't get confused about the removed dylib version of librlib
$(RUSTC) prog.rs && exit 1 || exit 0