summaryrefslogtreecommitdiffstats
path: root/tests/run-make/no-builtins-attribute/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/no-builtins-attribute/Makefile')
-rw-r--r--tests/run-make/no-builtins-attribute/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/run-make/no-builtins-attribute/Makefile b/tests/run-make/no-builtins-attribute/Makefile
new file mode 100644
index 000000000..0ce95faca
--- /dev/null
+++ b/tests/run-make/no-builtins-attribute/Makefile
@@ -0,0 +1,9 @@
+include ../tools.mk
+
+# We want to check if `no-builtins` is also added to the function declarations in the used crate.
+
+all:
+ $(RUSTC) no_builtins.rs --emit=link
+ $(RUSTC) main.rs --emit=llvm-ir
+
+ cat "$(TMPDIR)"/main.ll | "$(LLVM_FILECHECK)" filecheck.main.txt