summaryrefslogtreecommitdiffstats
path: root/tests/run-make/no-builtins-lto
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/no-builtins-lto')
-rw-r--r--tests/run-make/no-builtins-lto/Makefile9
-rw-r--r--tests/run-make/no-builtins-lto/main.rs3
-rw-r--r--tests/run-make/no-builtins-lto/no_builtins.rs2
3 files changed, 14 insertions, 0 deletions
diff --git a/tests/run-make/no-builtins-lto/Makefile b/tests/run-make/no-builtins-lto/Makefile
new file mode 100644
index 000000000..c8f05d991
--- /dev/null
+++ b/tests/run-make/no-builtins-lto/Makefile
@@ -0,0 +1,9 @@
+include ../tools.mk
+
+all:
+ # Compile a `#![no_builtins]` rlib crate
+ $(RUSTC) no_builtins.rs
+ # Build an executable that depends on that crate using LTO. The no_builtins crate doesn't
+ # participate in LTO, so its rlib must be explicitly linked into the final binary. Verify this by
+ # grepping the linker arguments.
+ $(RUSTC) main.rs -C lto --print link-args | $(CGREP) 'libno_builtins.rlib'
diff --git a/tests/run-make/no-builtins-lto/main.rs b/tests/run-make/no-builtins-lto/main.rs
new file mode 100644
index 000000000..890c999c8
--- /dev/null
+++ b/tests/run-make/no-builtins-lto/main.rs
@@ -0,0 +1,3 @@
+extern crate no_builtins;
+
+fn main() {}
diff --git a/tests/run-make/no-builtins-lto/no_builtins.rs b/tests/run-make/no-builtins-lto/no_builtins.rs
new file mode 100644
index 000000000..5d001031a
--- /dev/null
+++ b/tests/run-make/no-builtins-lto/no_builtins.rs
@@ -0,0 +1,2 @@
+#![crate_type = "lib"]
+#![no_builtins]