summaryrefslogtreecommitdiffstats
path: root/tests/run-make/output-with-hyphens
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/output-with-hyphens')
-rw-r--r--tests/run-make/output-with-hyphens/Makefile8
-rw-r--r--tests/run-make/output-with-hyphens/foo-bar.rs1
2 files changed, 9 insertions, 0 deletions
diff --git a/tests/run-make/output-with-hyphens/Makefile b/tests/run-make/output-with-hyphens/Makefile
new file mode 100644
index 000000000..846c9a66a
--- /dev/null
+++ b/tests/run-make/output-with-hyphens/Makefile
@@ -0,0 +1,8 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all:
+ $(RUSTC) foo-bar.rs --crate-type bin
+ [ -f $(TMPDIR)/$(call BIN,foo-bar) ]
+ $(RUSTC) foo-bar.rs --crate-type lib
+ [ -f $(TMPDIR)/libfoo_bar.rlib ]
diff --git a/tests/run-make/output-with-hyphens/foo-bar.rs b/tests/run-make/output-with-hyphens/foo-bar.rs
new file mode 100644
index 000000000..f328e4d9d
--- /dev/null
+++ b/tests/run-make/output-with-hyphens/foo-bar.rs
@@ -0,0 +1 @@
+fn main() {}