summaryrefslogtreecommitdiffstats
path: root/tests/run-make/pass-linker-flags-from-dep/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/pass-linker-flags-from-dep/Makefile')
-rw-r--r--tests/run-make/pass-linker-flags-from-dep/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/run-make/pass-linker-flags-from-dep/Makefile b/tests/run-make/pass-linker-flags-from-dep/Makefile
new file mode 100644
index 000000000..b9426326a
--- /dev/null
+++ b/tests/run-make/pass-linker-flags-from-dep/Makefile
@@ -0,0 +1,10 @@
+include ../../run-make-fulldeps/tools.mk
+
+all:
+ # Build deps
+ $(RUSTC) native_dep_1.rs --crate-type=staticlib
+ $(RUSTC) native_dep_2.rs --crate-type=staticlib
+ $(RUSTC) rust_dep.rs -l static:-bundle=native_dep_1 -l link-arg=some_flag -l static:-bundle=native_dep_2 --crate-type=lib -Z unstable-options
+
+ # Check sequence of linker args
+ $(RUSTC) main.rs --extern lib=$(TMPDIR)/librust_dep.rlib --crate-type=bin --print link-args | $(CGREP) -e 'native_dep_1.*some_flag.*native_dep_2'