summaryrefslogtreecommitdiffstats
path: root/tests/run-make/pointer-auth-link-with-c/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/pointer-auth-link-with-c/Makefile')
-rw-r--r--tests/run-make/pointer-auth-link-with-c/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/run-make/pointer-auth-link-with-c/Makefile b/tests/run-make/pointer-auth-link-with-c/Makefile
index 7acea0380..dffbd3035 100644
--- a/tests/run-make/pointer-auth-link-with-c/Makefile
+++ b/tests/run-make/pointer-auth-link-with-c/Makefile
@@ -5,10 +5,10 @@ include ../tools.mk
all:
$(COMPILE_OBJ) $(TMPDIR)/test.o test.c
$(AR) rcs $(TMPDIR)/libtest.a $(TMPDIR)/test.o
- $(RUSTC) -Z branch-protection=bti,pac-ret,leaf test.rs
+ $(RUSTC) --target $(TARGET) -Z branch-protection=bti,pac-ret,leaf test.rs
$(call RUN,test)
$(COMPILE_OBJ) $(TMPDIR)/test.o test.c -mbranch-protection=bti+pac-ret+leaf
$(AR) rcs $(TMPDIR)/libtest.a $(TMPDIR)/test.o
- $(RUSTC) -Z branch-protection=bti,pac-ret,leaf test.rs
+ $(RUSTC) --target $(TARGET) -Z branch-protection=bti,pac-ret,leaf test.rs
$(call RUN,test)