summaryrefslogtreecommitdiffstats
path: root/tests/run-make/pretty-print-to-file
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/pretty-print-to-file')
-rw-r--r--tests/run-make/pretty-print-to-file/Makefile5
-rw-r--r--tests/run-make/pretty-print-to-file/input.pp3
-rw-r--r--tests/run-make/pretty-print-to-file/input.rs5
3 files changed, 13 insertions, 0 deletions
diff --git a/tests/run-make/pretty-print-to-file/Makefile b/tests/run-make/pretty-print-to-file/Makefile
new file mode 100644
index 000000000..ca11b8c47
--- /dev/null
+++ b/tests/run-make/pretty-print-to-file/Makefile
@@ -0,0 +1,5 @@
+include ../tools.mk
+
+all:
+ $(RUSTC) -o $(TMPDIR)/input.out -Zunpretty=normal input.rs
+ diff -u $(TMPDIR)/input.out input.pp
diff --git a/tests/run-make/pretty-print-to-file/input.pp b/tests/run-make/pretty-print-to-file/input.pp
new file mode 100644
index 000000000..e3f03242a
--- /dev/null
+++ b/tests/run-make/pretty-print-to-file/input.pp
@@ -0,0 +1,3 @@
+
+#[crate_type = "lib"]
+pub fn foo() -> i32 { 45 }
diff --git a/tests/run-make/pretty-print-to-file/input.rs b/tests/run-make/pretty-print-to-file/input.rs
new file mode 100644
index 000000000..aa828155b
--- /dev/null
+++ b/tests/run-make/pretty-print-to-file/input.rs
@@ -0,0 +1,5 @@
+#[crate_type="lib"]
+
+pub fn
+foo() -> i32
+{ 45 }