summaryrefslogtreecommitdiffstats
path: root/tests/run-make/raw-dylib-custom-dlltool/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/raw-dylib-custom-dlltool/Makefile')
-rw-r--r--tests/run-make/raw-dylib-custom-dlltool/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/run-make/raw-dylib-custom-dlltool/Makefile b/tests/run-make/raw-dylib-custom-dlltool/Makefile
new file mode 100644
index 000000000..f5d5360a3
--- /dev/null
+++ b/tests/run-make/raw-dylib-custom-dlltool/Makefile
@@ -0,0 +1,11 @@
+# Test using -Cdlltool to change where raw-dylib looks for the dlltool binary.
+
+# only-windows
+# only-gnu
+# needs-dlltool
+
+include ../tools.mk
+
+all:
+ $(RUSTC) --crate-type lib --crate-name raw_dylib_test lib.rs -Cdlltool=$(CURDIR)/script.cmd
+ $(DIFF) output.txt "$(TMPDIR)"/output.txt