summaryrefslogtreecommitdiffstats
path: root/tests/run-make/redundant-libs
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/redundant-libs')
-rw-r--r--tests/run-make/redundant-libs/Makefile24
-rw-r--r--tests/run-make/redundant-libs/bar.c1
-rw-r--r--tests/run-make/redundant-libs/baz.c7
-rw-r--r--tests/run-make/redundant-libs/foo.c2
-rw-r--r--tests/run-make/redundant-libs/main.rs11
5 files changed, 45 insertions, 0 deletions
diff --git a/tests/run-make/redundant-libs/Makefile b/tests/run-make/redundant-libs/Makefile
new file mode 100644
index 000000000..0a48b2b28
--- /dev/null
+++ b/tests/run-make/redundant-libs/Makefile
@@ -0,0 +1,24 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# ignore-windows-msvc
+
+# rustc will remove one of the two redundant references to foo below. Depending
+# on which one gets removed, we'll get a linker error on SOME platforms (like
+# Linux). On these platforms, when a library is referenced, the linker will
+# only pull in the symbols needed _at that point in time_. If a later library
+# depends on additional symbols from the library, they will not have been pulled
+# in, and you'll get undefined symbols errors.
+#
+# So in this example, we need to ensure that rustc keeps the _later_ reference
+# to foo, and not the former one.
+RUSTC_FLAGS = \
+ -l static=bar \
+ -l foo \
+ -l static=baz \
+ -l foo \
+ --print link-args
+
+all: $(call DYLIB,foo) $(call STATICLIB,bar) $(call STATICLIB,baz)
+ $(RUSTC) $(RUSTC_FLAGS) main.rs
+ $(call RUN,main)
diff --git a/tests/run-make/redundant-libs/bar.c b/tests/run-make/redundant-libs/bar.c
new file mode 100644
index 000000000..e42599986
--- /dev/null
+++ b/tests/run-make/redundant-libs/bar.c
@@ -0,0 +1 @@
+void bar() {}
diff --git a/tests/run-make/redundant-libs/baz.c b/tests/run-make/redundant-libs/baz.c
new file mode 100644
index 000000000..a4e2c2b71
--- /dev/null
+++ b/tests/run-make/redundant-libs/baz.c
@@ -0,0 +1,7 @@
+extern void foo1();
+extern void foo2();
+
+void baz() {
+ foo1();
+ foo2();
+}
diff --git a/tests/run-make/redundant-libs/foo.c b/tests/run-make/redundant-libs/foo.c
new file mode 100644
index 000000000..339ee86c9
--- /dev/null
+++ b/tests/run-make/redundant-libs/foo.c
@@ -0,0 +1,2 @@
+void foo1() {}
+void foo2() {}
diff --git a/tests/run-make/redundant-libs/main.rs b/tests/run-make/redundant-libs/main.rs
new file mode 100644
index 000000000..90d185ff5
--- /dev/null
+++ b/tests/run-make/redundant-libs/main.rs
@@ -0,0 +1,11 @@
+extern "C" {
+ fn bar();
+ fn baz();
+}
+
+fn main() {
+ unsafe {
+ bar();
+ baz();
+ }
+}