summaryrefslogtreecommitdiffstats
path: root/tests/run-make/rust-lld-custom-target/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/rust-lld-custom-target/Makefile')
-rw-r--r--tests/run-make/rust-lld-custom-target/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/run-make/rust-lld-custom-target/Makefile b/tests/run-make/rust-lld-custom-target/Makefile
new file mode 100644
index 000000000..007493ab0
--- /dev/null
+++ b/tests/run-make/rust-lld-custom-target/Makefile
@@ -0,0 +1,7 @@
+include ../tools.mk
+
+# needs-rust-lld
+# only-x86_64-unknown-linux-gnu
+all:
+ RUSTC_LOG=rustc_codegen_ssa::back::link=info $(RUSTC) --crate-type cdylib --target custom-target.json -Clink-args=-Wl,-v lib.rs 2> $(TMPDIR)/output.txt
+ $(CGREP) -e "^LLD [0-9]+\.[0-9]+\.[0-9]+" < $(TMPDIR)/output.txt