summaryrefslogtreecommitdiffstats
path: root/tests/run-make/rustdoc-scrape-examples-ordering
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/rustdoc-scrape-examples-ordering')
-rw-r--r--tests/run-make/rustdoc-scrape-examples-ordering/Makefile5
-rw-r--r--tests/run-make/rustdoc-scrape-examples-ordering/examples/ex1.rs11
-rw-r--r--tests/run-make/rustdoc-scrape-examples-ordering/examples/ex2.rs8
-rw-r--r--tests/run-make/rustdoc-scrape-examples-ordering/src/lib.rs6
4 files changed, 30 insertions, 0 deletions
diff --git a/tests/run-make/rustdoc-scrape-examples-ordering/Makefile b/tests/run-make/rustdoc-scrape-examples-ordering/Makefile
new file mode 100644
index 000000000..bf45b8148
--- /dev/null
+++ b/tests/run-make/rustdoc-scrape-examples-ordering/Makefile
@@ -0,0 +1,5 @@
+deps := ex1 ex2
+
+include ../rustdoc-scrape-examples-multiple/scrape.mk
+
+all: scrape
diff --git a/tests/run-make/rustdoc-scrape-examples-ordering/examples/ex1.rs b/tests/run-make/rustdoc-scrape-examples-ordering/examples/ex1.rs
new file mode 100644
index 000000000..05c18007b
--- /dev/null
+++ b/tests/run-make/rustdoc-scrape-examples-ordering/examples/ex1.rs
@@ -0,0 +1,11 @@
+fn main() {
+ foobar::ok(0);
+
+ // this is a
+
+ // ..
+
+ // BIG
+
+ // item
+}
diff --git a/tests/run-make/rustdoc-scrape-examples-ordering/examples/ex2.rs b/tests/run-make/rustdoc-scrape-examples-ordering/examples/ex2.rs
new file mode 100644
index 000000000..de21d9061
--- /dev/null
+++ b/tests/run-make/rustdoc-scrape-examples-ordering/examples/ex2.rs
@@ -0,0 +1,8 @@
+fn main() {
+ foobar::ok(1);
+ // small item
+}
+
+fn f() {
+ foobar::ok(2);
+}
diff --git a/tests/run-make/rustdoc-scrape-examples-ordering/src/lib.rs b/tests/run-make/rustdoc-scrape-examples-ordering/src/lib.rs
new file mode 100644
index 000000000..c53c987a7
--- /dev/null
+++ b/tests/run-make/rustdoc-scrape-examples-ordering/src/lib.rs
@@ -0,0 +1,6 @@
+// @has foobar/fn.ok.html '//*[@class="docblock scraped-example-list"]' 'ex2'
+// @has foobar/fn.ok.html '//*[@class="more-scraped-examples"]' 'ex1'
+// @has foobar/fn.ok.html '//*[@class="highlight focus"]' 'ok'
+// @has foobar/fn.ok.html '//*[@class="highlight"]' 'ok'
+
+pub fn ok(_x: i32) {}