summaryrefslogtreecommitdiffstats
path: root/tests/run-make/rustdoc-target-spec-json-path
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/rustdoc-target-spec-json-path')
-rw-r--r--tests/run-make/rustdoc-target-spec-json-path/Makefile9
-rw-r--r--tests/run-make/rustdoc-target-spec-json-path/dummy_core.rs2
-rw-r--r--tests/run-make/rustdoc-target-spec-json-path/my_crate.rs3
-rw-r--r--tests/run-make/rustdoc-target-spec-json-path/target.json38
4 files changed, 52 insertions, 0 deletions
diff --git a/tests/run-make/rustdoc-target-spec-json-path/Makefile b/tests/run-make/rustdoc-target-spec-json-path/Makefile
new file mode 100644
index 000000000..6d0bc4186
--- /dev/null
+++ b/tests/run-make/rustdoc-target-spec-json-path/Makefile
@@ -0,0 +1,9 @@
+include ../tools.mk
+
+# Test that rustdoc will properly canonicalize the target spec json path just like rustc
+
+OUTPUT_DIR := "$(TMPDIR)/rustdoc-target-spec-json-path"
+
+all:
+ $(RUSTC) --crate-type lib dummy_core.rs --target target.json
+ $(RUSTDOC) -o $(OUTPUT_DIR) -L $(TMPDIR) my_crate.rs --target target.json
diff --git a/tests/run-make/rustdoc-target-spec-json-path/dummy_core.rs b/tests/run-make/rustdoc-target-spec-json-path/dummy_core.rs
new file mode 100644
index 000000000..da27b7f34
--- /dev/null
+++ b/tests/run-make/rustdoc-target-spec-json-path/dummy_core.rs
@@ -0,0 +1,2 @@
+#![feature(no_core)]
+#![no_core]
diff --git a/tests/run-make/rustdoc-target-spec-json-path/my_crate.rs b/tests/run-make/rustdoc-target-spec-json-path/my_crate.rs
new file mode 100644
index 000000000..12aa08220
--- /dev/null
+++ b/tests/run-make/rustdoc-target-spec-json-path/my_crate.rs
@@ -0,0 +1,3 @@
+#![feature(no_core)]
+#![no_core]
+extern crate dummy_core;
diff --git a/tests/run-make/rustdoc-target-spec-json-path/target.json b/tests/run-make/rustdoc-target-spec-json-path/target.json
new file mode 100644
index 000000000..34357182c
--- /dev/null
+++ b/tests/run-make/rustdoc-target-spec-json-path/target.json
@@ -0,0 +1,38 @@
+{
+ "arch": "x86_64",
+ "cpu": "x86-64",
+ "crt-static-respected": true,
+ "data-layout": "e-m:e-p270:32:32-p271:32:32-p272:64:64-i64:64-f80:128-n8:16:32:64-S128",
+ "dynamic-linking": true,
+ "env": "gnu",
+ "executables": true,
+ "has-elf-tls": true,
+ "has-rpath": true,
+ "linker-is-gnu": true,
+ "llvm-target": "x86_64-unknown-linux-gnu",
+ "max-atomic-width": 64,
+ "os": "linux",
+ "position-independent-executables": true,
+ "pre-link-args": {
+ "gcc": [
+ "-m64"
+ ]
+ },
+ "relro-level": "full",
+ "stack-probes": {
+ "kind": "inline-or-call",
+ "min-llvm-version-for-inline": [
+ 11,
+ 0,
+ 1
+ ]
+ },
+ "supported-sanitizers": [
+ "address",
+ "leak",
+ "memory",
+ "thread"
+ ],
+ "target-family": "unix",
+ "target-pointer-width": "64"
+}