summaryrefslogtreecommitdiffstats
path: root/tests/run-make/rustdoc-themes
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/rustdoc-themes')
-rw-r--r--tests/run-make/rustdoc-themes/Makefile10
-rw-r--r--tests/run-make/rustdoc-themes/foo.rs4
2 files changed, 14 insertions, 0 deletions
diff --git a/tests/run-make/rustdoc-themes/Makefile b/tests/run-make/rustdoc-themes/Makefile
new file mode 100644
index 000000000..a6d9a43ad
--- /dev/null
+++ b/tests/run-make/rustdoc-themes/Makefile
@@ -0,0 +1,10 @@
+include ../tools.mk
+
+# Test that rustdoc will properly load in a theme file and display it in the theme selector.
+
+OUTPUT_DIR := "$(TMPDIR)/rustdoc-themes"
+
+all:
+ cp $(S)/src/librustdoc/html/static/css/themes/light.css $(TMPDIR)/test.css
+ $(RUSTDOC) -o $(OUTPUT_DIR) foo.rs --theme $(TMPDIR)/test.css
+ $(HTMLDOCCK) $(OUTPUT_DIR) foo.rs
diff --git a/tests/run-make/rustdoc-themes/foo.rs b/tests/run-make/rustdoc-themes/foo.rs
new file mode 100644
index 000000000..995544aef
--- /dev/null
+++ b/tests/run-make/rustdoc-themes/foo.rs
@@ -0,0 +1,4 @@
+// @has test.css
+// @has foo/struct.Foo.html
+// @has - '//*[@id="rustdoc-vars"]/@data-themes' 'test'
+pub struct Foo;