summaryrefslogtreecommitdiffstats
path: root/tests/run-make/rustdoc-with-output-option/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/rustdoc-with-output-option/Makefile')
-rw-r--r--tests/run-make/rustdoc-with-output-option/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/run-make/rustdoc-with-output-option/Makefile b/tests/run-make/rustdoc-with-output-option/Makefile
new file mode 100644
index 000000000..02093a35c
--- /dev/null
+++ b/tests/run-make/rustdoc-with-output-option/Makefile
@@ -0,0 +1,8 @@
+include ../../run-make-fulldeps/tools.mk
+
+OUTPUT_DIR := "$(TMPDIR)/rustdoc"
+
+all:
+ $(RUSTDOC) src/lib.rs --crate-name foobar --crate-type lib --output $(OUTPUT_DIR)
+
+ $(HTMLDOCCK) $(OUTPUT_DIR) src/lib.rs