summaryrefslogtreecommitdiffstats
path: root/tests/run-make/share-generics-dylib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tests/run-make/share-generics-dylib/Makefile (renamed from tests/run-make-fulldeps/share-generics-dylib/Makefile)3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/run-make-fulldeps/share-generics-dylib/Makefile b/tests/run-make/share-generics-dylib/Makefile
index 065fb574c..9d97eca80 100644
--- a/tests/run-make-fulldeps/share-generics-dylib/Makefile
+++ b/tests/run-make/share-generics-dylib/Makefile
@@ -1,3 +1,4 @@
+# ignore-cross-compile
# This test makes sure all generic instances get re-exported from Rust dylibs for use by
# `-Zshare-generics`. There are two rlibs (`instance_provider_a` and `instance_provider_b`)
# which both provide an instance of `Cell<i32>::set`. There is `instance_user_dylib` which is
@@ -9,7 +10,7 @@
#
# This is regression test for https://github.com/rust-lang/rust/issues/67276.
-include ../../run-make-fulldeps/tools.mk
+include ../tools.mk
COMMON_ARGS=-Cprefer-dynamic -Zshare-generics=yes -Ccodegen-units=1 -Csymbol-mangling-version=v0