summaryrefslogtreecommitdiffstats
path: root/tests/run-make/staticlib-dylib-linkage/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/staticlib-dylib-linkage/Makefile')
-rw-r--r--tests/run-make/staticlib-dylib-linkage/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/run-make/staticlib-dylib-linkage/Makefile b/tests/run-make/staticlib-dylib-linkage/Makefile
new file mode 100644
index 000000000..a1e86a7ce
--- /dev/null
+++ b/tests/run-make/staticlib-dylib-linkage/Makefile
@@ -0,0 +1,21 @@
+include ../tools.mk
+
+# ignore-cross-compile
+# ignore-msvc FIXME(bjorn3) can't figure out how to link with the MSVC toolchain
+# ignore-wasm wasm doesn't support dynamic libraries
+
+all:
+ $(RUSTC) -C prefer-dynamic bar.rs
+ $(RUSTC) foo.rs --crate-type staticlib --print native-static-libs \
+ -Z staticlib-allow-rdylib-deps 2>&1 | grep 'note: native-static-libs: ' \
+ | sed 's/note: native-static-libs: \(.*\)/\1/' > $(TMPDIR)/libs.txt
+ cat $(TMPDIR)/libs.txt
+
+ifdef IS_MSVC
+ $(CC) $(CFLAGS) /c foo.c /Fo:$(TMPDIR)/foo.o
+ $(RUSTC_LINKER) $(TMPDIR)/foo.o $(TMPDIR)/foo.lib $$(cat $(TMPDIR)/libs.txt) $(call OUT_EXE,foo)
+else
+ $(CC) $(CFLAGS) foo.c -L $(TMPDIR) -lfoo $$(cat $(TMPDIR)/libs.txt) -o $(call RUN_BINFILE,foo)
+endif
+
+ $(call RUN,foo)