summaryrefslogtreecommitdiffstats
path: root/tests/run-make/stdin-non-utf8
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/stdin-non-utf8')
-rw-r--r--tests/run-make/stdin-non-utf8/Makefile6
-rw-r--r--tests/run-make/stdin-non-utf8/non-utf81
2 files changed, 7 insertions, 0 deletions
diff --git a/tests/run-make/stdin-non-utf8/Makefile b/tests/run-make/stdin-non-utf8/Makefile
new file mode 100644
index 000000000..709d4cf14
--- /dev/null
+++ b/tests/run-make/stdin-non-utf8/Makefile
@@ -0,0 +1,6 @@
+include ../tools.mk
+
+all:
+ cp non-utf8 $(TMPDIR)/non-utf.rs
+ cat $(TMPDIR)/non-utf.rs | $(RUSTC) - 2>&1 \
+ | $(CGREP) "error: couldn't read from stdin, as it did not contain valid UTF-8"
diff --git a/tests/run-make/stdin-non-utf8/non-utf8 b/tests/run-make/stdin-non-utf8/non-utf8
new file mode 100644
index 000000000..bc87051a8
--- /dev/null
+++ b/tests/run-make/stdin-non-utf8/non-utf8
@@ -0,0 +1 @@