summaryrefslogtreecommitdiffstats
path: root/tests/run-make/suspicious-library
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/suspicious-library')
-rw-r--r--tests/run-make/suspicious-library/Makefile8
-rw-r--r--tests/run-make/suspicious-library/bar.rs3
-rw-r--r--tests/run-make/suspicious-library/foo.rs3
3 files changed, 14 insertions, 0 deletions
diff --git a/tests/run-make/suspicious-library/Makefile b/tests/run-make/suspicious-library/Makefile
new file mode 100644
index 000000000..3b5ab3c53
--- /dev/null
+++ b/tests/run-make/suspicious-library/Makefile
@@ -0,0 +1,8 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all:
+ $(RUSTC) foo.rs -C prefer-dynamic
+ touch $(call DYLIB,foo-something-special)
+ touch $(call DYLIB,foo-something-special2)
+ $(RUSTC) bar.rs
diff --git a/tests/run-make/suspicious-library/bar.rs b/tests/run-make/suspicious-library/bar.rs
new file mode 100644
index 000000000..550c94cd0
--- /dev/null
+++ b/tests/run-make/suspicious-library/bar.rs
@@ -0,0 +1,3 @@
+extern crate foo;
+
+fn main() { foo::foo() }
diff --git a/tests/run-make/suspicious-library/foo.rs b/tests/run-make/suspicious-library/foo.rs
new file mode 100644
index 000000000..a382d8f2c
--- /dev/null
+++ b/tests/run-make/suspicious-library/foo.rs
@@ -0,0 +1,3 @@
+#![crate_type = "dylib"]
+
+pub fn foo() {}