summaryrefslogtreecommitdiffstats
path: root/tests/run-make/symlinked-libraries
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/symlinked-libraries')
-rw-r--r--tests/run-make/symlinked-libraries/Makefile11
-rw-r--r--tests/run-make/symlinked-libraries/bar.rs5
-rw-r--r--tests/run-make/symlinked-libraries/foo.rs3
3 files changed, 19 insertions, 0 deletions
diff --git a/tests/run-make/symlinked-libraries/Makefile b/tests/run-make/symlinked-libraries/Makefile
new file mode 100644
index 000000000..fb0b6127e
--- /dev/null
+++ b/tests/run-make/symlinked-libraries/Makefile
@@ -0,0 +1,11 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# ignore-windows
+# `ln` is actually `cp` on msys.
+
+all:
+ $(RUSTC) foo.rs -C prefer-dynamic
+ mkdir -p $(TMPDIR)/other
+ ln -nsf $(TMPDIR)/$(call DYLIB_GLOB,foo) $(TMPDIR)/other
+ $(RUSTC) bar.rs -L $(TMPDIR)/other
diff --git a/tests/run-make/symlinked-libraries/bar.rs b/tests/run-make/symlinked-libraries/bar.rs
new file mode 100644
index 000000000..fde0d7466
--- /dev/null
+++ b/tests/run-make/symlinked-libraries/bar.rs
@@ -0,0 +1,5 @@
+extern crate foo;
+
+fn main() {
+ foo::bar();
+}
diff --git a/tests/run-make/symlinked-libraries/foo.rs b/tests/run-make/symlinked-libraries/foo.rs
new file mode 100644
index 000000000..cde9e291b
--- /dev/null
+++ b/tests/run-make/symlinked-libraries/foo.rs
@@ -0,0 +1,3 @@
+#![crate_type = "dylib"]
+
+pub fn bar() {}