summaryrefslogtreecommitdiffstats
path: root/tests/run-make/translation/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/translation/Makefile')
-rw-r--r--tests/run-make/translation/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/run-make/translation/Makefile b/tests/run-make/translation/Makefile
index 0acf64e5d..07e0547cf 100644
--- a/tests/run-make/translation/Makefile
+++ b/tests/run-make/translation/Makefile
@@ -46,6 +46,8 @@ sysroot: test.rs working.ftl
rm -f $(FAKEROOT)/lib/rustlib/src
mkdir $(FAKEROOT)/lib/rustlib/src
ln -s $(SYSROOT)/lib/rustlib/src/* $(FAKEROOT)/lib/rustlib/src
+ # When download-rustc is enabled, `$(SYSROOT)` will have a share directory. Delete the link to it.
+ rm -f $(FAKEROOT)/share
mkdir -p $(FAKEROOT)/share/locale/zh-CN/
ln -s $(CURDIR)/working.ftl $(FAKEROOT)/share/locale/zh-CN/basic-translation.ftl
$(RUSTC) $< --sysroot $(FAKEROOT) -Ztranslate-lang=zh-CN 2>&1 | $(CGREP) "this is a test message"