summaryrefslogtreecommitdiffstats
path: root/tests/run-make/wasm-custom-sections-opt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/wasm-custom-sections-opt')
-rw-r--r--tests/run-make/wasm-custom-sections-opt/Makefile7
-rw-r--r--tests/run-make/wasm-custom-sections-opt/foo.js15
-rw-r--r--tests/run-make/wasm-custom-sections-opt/foo.rs21
3 files changed, 43 insertions, 0 deletions
diff --git a/tests/run-make/wasm-custom-sections-opt/Makefile b/tests/run-make/wasm-custom-sections-opt/Makefile
new file mode 100644
index 000000000..e5b45d963
--- /dev/null
+++ b/tests/run-make/wasm-custom-sections-opt/Makefile
@@ -0,0 +1,7 @@
+include ../../run-make-fulldeps/tools.mk
+
+# only-wasm32-bare
+
+all:
+ $(RUSTC) foo.rs -O --target wasm32-unknown-unknown
+ $(NODE) foo.js $(TMPDIR)/foo.wasm
diff --git a/tests/run-make/wasm-custom-sections-opt/foo.js b/tests/run-make/wasm-custom-sections-opt/foo.js
new file mode 100644
index 000000000..9663f377e
--- /dev/null
+++ b/tests/run-make/wasm-custom-sections-opt/foo.js
@@ -0,0 +1,15 @@
+const fs = require('fs');
+const process = require('process');
+const assert = require('assert');
+const buffer = fs.readFileSync(process.argv[2]);
+
+let m = new WebAssembly.Module(buffer);
+
+sections = WebAssembly.Module.customSections(m, "foo");
+console.log('section foo', sections);
+assert.strictEqual(sections.length, 1, "didn't create `foo` section");
+section = new Uint8Array(sections[0]);
+console.log('contents', section);
+assert.strictEqual(section.length, 4, "didn't concatenate `foo` sections");
+
+process.exit(0);
diff --git a/tests/run-make/wasm-custom-sections-opt/foo.rs b/tests/run-make/wasm-custom-sections-opt/foo.rs
new file mode 100644
index 000000000..9af7728b7
--- /dev/null
+++ b/tests/run-make/wasm-custom-sections-opt/foo.rs
@@ -0,0 +1,21 @@
+#![crate_type = "cdylib"]
+#![deny(warnings)]
+
+#[link_section = "foo"]
+pub static A: [u8; 2] = [1, 2];
+
+// make sure this is in another CGU
+pub mod another {
+ #[link_section = "foo"]
+ pub static FOO: [u8; 2] = [3, 4];
+
+ pub fn foo() {}
+}
+
+#[no_mangle]
+pub extern fn foo() {
+ // This will import `another::foo` through ThinLTO passes, and it better not
+ // also accidentally import the `FOO` custom section into this module as
+ // well
+ another::foo();
+}