summaryrefslogtreecommitdiffstats
path: root/tests/run-make/wasm-exceptions-nostd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tests/run-make/wasm-exceptions-nostd/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make/wasm-exceptions-nostd/Makefile b/tests/run-make/wasm-exceptions-nostd/Makefile
new file mode 100644
index 000000000..34755ec14
--- /dev/null
+++ b/tests/run-make/wasm-exceptions-nostd/Makefile
@@ -0,0 +1,12 @@
+include ../tools.mk
+
+# only-wasm32-bare
+
+# Add a few command line args to make exceptions work
+RUSTC := $(RUSTC) -C llvm-args=-wasm-enable-eh
+RUSTC := $(RUSTC) -C target-feature=+exception-handling
+RUSTC := $(RUSTC) -C panic=unwind
+
+all:
+ $(RUSTC) src/lib.rs --target wasm32-unknown-unknown
+ $(NODE) verify.mjs $(TMPDIR)/lib.wasm