summaryrefslogtreecommitdiffstats
path: root/tests/run-make/wasm-stringify-ints-small/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/wasm-stringify-ints-small/Makefile')
-rw-r--r--tests/run-make/wasm-stringify-ints-small/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/run-make/wasm-stringify-ints-small/Makefile b/tests/run-make/wasm-stringify-ints-small/Makefile
new file mode 100644
index 000000000..2fa2c954d
--- /dev/null
+++ b/tests/run-make/wasm-stringify-ints-small/Makefile
@@ -0,0 +1,10 @@
+include ../../run-make-fulldeps/tools.mk
+
+ifeq ($(TARGET),wasm32-unknown-unknown)
+all:
+ $(RUSTC) foo.rs -C lto -O --target wasm32-unknown-unknown
+ wc -c < $(TMPDIR)/foo.wasm
+ [ "`wc -c < $(TMPDIR)/foo.wasm`" -lt "25000" ]
+else
+all:
+endif