summaryrefslogtreecommitdiffstats
path: root/vendor/ahash/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/ahash/Cargo.toml')
-rw-r--r--vendor/ahash/Cargo.toml13
1 files changed, 9 insertions, 4 deletions
diff --git a/vendor/ahash/Cargo.toml b/vendor/ahash/Cargo.toml
index a027c55a5..934051dfb 100644
--- a/vendor/ahash/Cargo.toml
+++ b/vendor/ahash/Cargo.toml
@@ -12,7 +12,7 @@
[package]
edition = "2018"
name = "ahash"
-version = "0.8.3"
+version = "0.8.6"
authors = ["Tom Kaitchuck <Tom.Kaitchuck@gmail.com>"]
build = "./build.rs"
exclude = [
@@ -38,6 +38,7 @@ license = "MIT OR Apache-2.0"
repository = "https://github.com/tkaitchuck/ahash"
[package.metadata.docs.rs]
+features = ["std"]
rustc-args = [
"-C",
"target-feature=+aes",
@@ -46,20 +47,19 @@ rustdoc-args = [
"-C",
"target-feature=+aes",
]
-features = ["std"]
[profile.bench]
opt-level = 3
lto = "fat"
codegen-units = 1
-debug = false
+debug = 0
debug-assertions = false
[profile.release]
opt-level = 3
lto = "fat"
codegen-units = 1
-debug = false
+debug = 0
debug-assertions = false
[profile.test]
@@ -103,6 +103,11 @@ optional = true
version = "1.0.117"
optional = true
+[dependencies.zerocopy]
+version = "0.7.14"
+features = ["simd"]
+default-features = false
+
[dev-dependencies.criterion]
version = "0.3.2"
features = ["html_reports"]