summaryrefslogtreecommitdiffstats
path: root/vendor/arbitrary/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/arbitrary/Cargo.toml')
-rw-r--r--vendor/arbitrary/Cargo.toml53
1 files changed, 53 insertions, 0 deletions
diff --git a/vendor/arbitrary/Cargo.toml b/vendor/arbitrary/Cargo.toml
new file mode 100644
index 000000000..41c482d5d
--- /dev/null
+++ b/vendor/arbitrary/Cargo.toml
@@ -0,0 +1,53 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.63.0"
+name = "arbitrary"
+version = "1.3.2"
+authors = [
+ "The Rust-Fuzz Project Developers",
+ "Nick Fitzgerald <fitzgen@gmail.com>",
+ "Manish Goregaokar <manishsmail@gmail.com>",
+ "Simonas Kazlauskas <arbitrary@kazlauskas.me>",
+ "Brian L. Troutwine <brian@troutwine.us>",
+ "Corey Farwell <coreyf@rwell.org>",
+]
+description = "The trait for generating structured data from unstructured data"
+documentation = "https://docs.rs/arbitrary/"
+readme = "README.md"
+keywords = [
+ "arbitrary",
+ "testing",
+]
+categories = ["development-tools::testing"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-fuzz/arbitrary/"
+
+[[example]]
+name = "derive_enum"
+required-features = ["derive"]
+
+[[test]]
+name = "derive"
+path = "./tests/derive.rs"
+required-features = ["derive"]
+
+[dependencies.derive_arbitrary]
+version = "1.3.2"
+optional = true
+
+[dev-dependencies.exhaustigen]
+version = "0.1.0"
+
+[features]
+derive = ["derive_arbitrary"]