summaryrefslogtreecommitdiffstats
path: root/vendor/base16ct
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/base16ct')
-rw-r--r--vendor/base16ct/.cargo-checksum.json2
-rw-r--r--vendor/base16ct/CHANGELOG.md8
-rw-r--r--vendor/base16ct/Cargo.toml30
-rw-r--r--vendor/base16ct/README.md6
-rw-r--r--vendor/base16ct/src/lib.rs24
-rw-r--r--vendor/base16ct/src/lower.rs2
-rw-r--r--vendor/base16ct/src/mixed.rs1
-rw-r--r--vendor/base16ct/src/upper.rs2
8 files changed, 50 insertions, 25 deletions
diff --git a/vendor/base16ct/.cargo-checksum.json b/vendor/base16ct/.cargo-checksum.json
index 644cc2105..e2a9fd372 100644
--- a/vendor/base16ct/.cargo-checksum.json
+++ b/vendor/base16ct/.cargo-checksum.json
@@ -1 +1 @@
-{"files":{"CHANGELOG.md":"b74f249225e74ce70e911b3569a40e812d1941d13d5ef0ed6def2665943eca09","Cargo.toml":"d4406c7f39662e1feee04d54b308159eff624fe2f9b0127e0b14daaf7f03f861","LICENSE-APACHE":"a9040321c3712d8fd0b09cf52b17445de04a23a10165049ae187cd39e5c86be5","LICENSE-MIT":"0aa8963e105e8b6e02f634484145d4e5b0f42d0a6dd05c16f8148f033383adef","README.md":"3ec555623fab4feb5f805dbb0935a3408e8068b86f517c0b28edc171fd88f2a8","benches/mod.rs":"976e6c0443e69a0578a2cf2252c4ed486ff0dc39823d0c369625e31c89941657","src/display.rs":"7042d46254a4fe4c1d66fe41be90916010247fd6dbdf3e87532541aa1a199696","src/error.rs":"8c5ac9c8d2d3b6fe18d8cf56d7e48149fb4d44c32ccb71f566f243c70e9bb187","src/lib.rs":"75378dac02301ce69e419e58b98ff32f1f009f3cf4ef49b5c0791cdfa7d23abc","src/lower.rs":"d9a0a85be650d4d2b5154cd5886b95051314e6c5a53a9f8450dea2eeb1a0e553","src/mixed.rs":"f5fe584f2fb275ae28ce6c253b9faf8912038bbb83c331ad7f715c49ab8369a5","src/upper.rs":"5bae380ba3e515d4da7f498517d9f0ed9cf57416203a2d71474730f4bb4e6efe","tests/lib.rs":"1b5ae439670c8c1ca3843922bd484dc642b660d91f401a29fa279d9e01fdab92"},"package":"349a06037c7bf932dd7e7d1f653678b2038b9ad46a74102f1fc7bd7872678cce"} \ No newline at end of file
+{"files":{"CHANGELOG.md":"4804ca1b5d84da4177354125912a29ca7a9a6a4ebba5b752fcee61911c9fe23f","Cargo.toml":"5050aa1f3351bf8c11a55b9695a41f5ec4652c95d7243c5b45a301692e2782e6","LICENSE-APACHE":"a9040321c3712d8fd0b09cf52b17445de04a23a10165049ae187cd39e5c86be5","LICENSE-MIT":"0aa8963e105e8b6e02f634484145d4e5b0f42d0a6dd05c16f8148f033383adef","README.md":"535e9fe765cd20cc185be3458871253bca8ded1c2132e6e20ed3706044ddf2e9","benches/mod.rs":"976e6c0443e69a0578a2cf2252c4ed486ff0dc39823d0c369625e31c89941657","src/display.rs":"7042d46254a4fe4c1d66fe41be90916010247fd6dbdf3e87532541aa1a199696","src/error.rs":"8c5ac9c8d2d3b6fe18d8cf56d7e48149fb4d44c32ccb71f566f243c70e9bb187","src/lib.rs":"be52249977ee3d023a22beb0f805ad2d2bd69333cd17a0670c92002e57557ce9","src/lower.rs":"5ed8a602a6fbbe15c01c27a18a579a9df0599cecab7bd0420b26862c62ea91aa","src/mixed.rs":"12fc969194a5bf4776c9f1ccfd208c1abfa9e0abcd265a9b493f0af8382163dc","src/upper.rs":"c75c9b6ef7eddc5e23ef1699b1445ddf729e031a13e328c9e9b181e681daeec1","tests/lib.rs":"1b5ae439670c8c1ca3843922bd484dc642b660d91f401a29fa279d9e01fdab92"},"package":"4c7f02d4ea65f2c1853089ffd8d2787bdbc63de2f0d29dedbcf8ccdfa0ccd4cf"} \ No newline at end of file
diff --git a/vendor/base16ct/CHANGELOG.md b/vendor/base16ct/CHANGELOG.md
index 808c55253..3c3df348a 100644
--- a/vendor/base16ct/CHANGELOG.md
+++ b/vendor/base16ct/CHANGELOG.md
@@ -4,6 +4,14 @@ All notable changes to this project will be documented in this file.
The format is based on [Keep a Changelog](https://keepachangelog.com/en/1.0.0/),
and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.html).
+## 0.2.0 (2023-02-26)
+### Changed
+- MSRV 1.60 ([#802])
+- Lint improvements ([#824])
+
+[#802]: https://github.com/RustCrypto/formats/pull/802
+[#824]: https://github.com/RustCrypto/formats/pull/824
+
## 0.1.1 (2022-01-15)
### Added
- `HexDisplay` type ([#329])
diff --git a/vendor/base16ct/Cargo.toml b/vendor/base16ct/Cargo.toml
index dfeb08fdf..872816d76 100644
--- a/vendor/base16ct/Cargo.toml
+++ b/vendor/base16ct/Cargo.toml
@@ -11,21 +11,37 @@
[package]
edition = "2021"
-rust-version = "1.56"
+rust-version = "1.60"
name = "base16ct"
-version = "0.1.1"
+version = "0.2.0"
authors = ["RustCrypto Developers"]
-description = "Pure Rust implementation of Base16 a.k.a hexadecimal (RFC 4648) which avoids\nany usages of data-dependent branches/LUTs and thereby provides portable\n\"best effort\" constant-time operation and embedded-friendly no_std support\n"
+description = """
+Pure Rust implementation of Base16 a.k.a hexadecimal (RFC 4648) which avoids
+any usages of data-dependent branches/LUTs and thereby provides portable
+\"best effort\" constant-time operation and embedded-friendly no_std support
+"""
documentation = "https://docs.rs/base16ct"
readme = "README.md"
-keywords = ["crypto", "hex", "pem", "phc"]
-categories = ["cryptography", "encoding", "no-std", "parser-implementations"]
+keywords = [
+ "crypto",
+ "hex",
+ "hexadecimal",
+]
+categories = [
+ "cryptography",
+ "encoding",
+ "no-std",
+ "parser-implementations",
+]
license = "Apache-2.0 OR MIT"
repository = "https://github.com/RustCrypto/formats/tree/master/base16ct"
-resolver = "2"
+
[package.metadata.docs.rs]
all-features = true
-rustdoc-args = ["--cfg", "docsrs"]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
[features]
alloc = []
diff --git a/vendor/base16ct/README.md b/vendor/base16ct/README.md
index fad88dbf8..837c15618 100644
--- a/vendor/base16ct/README.md
+++ b/vendor/base16ct/README.md
@@ -20,7 +20,7 @@ Supports `no_std` environments and avoids heap allocations in the core API
## Minimum Supported Rust Version
-This crate requires **Rust 1.56** at a minimum.
+This crate requires **Rust 1.60** at a minimum.
We may change the MSRV in the future, but it will be accompanied by a minor
version bump.
@@ -42,14 +42,14 @@ dual licensed as above, without any additional terms or conditions.
[//]: # (badges)
-[crate-image]: https://img.shields.io/crates/v/base16ct.svg
+[crate-image]: https://buildstats.info/crate/base16ct
[crate-link]: https://crates.io/crates/base16ct
[docs-image]: https://docs.rs/base16ct/badge.svg
[docs-link]: https://docs.rs/base16ct/
[build-image]: https://github.com/RustCrypto/formats/actions/workflows/base16ct.yml/badge.svg
[build-link]: https://github.com/RustCrypto/formats/actions/workflows/base16ct.yml
[license-image]: https://img.shields.io/badge/license-Apache2.0/MIT-blue.svg
-[rustc-image]: https://img.shields.io/badge/rustc-1.56+-blue.svg
+[rustc-image]: https://img.shields.io/badge/rustc-1.60+-blue.svg
[chat-image]: https://img.shields.io/badge/zulip-join_chat-blue.svg
[chat-link]: https://rustcrypto.zulipchat.com/#narrow/stream/300570-formats
diff --git a/vendor/base16ct/src/lib.rs b/vendor/base16ct/src/lib.rs
index 413d512d8..435c50134 100644
--- a/vendor/base16ct/src/lib.rs
+++ b/vendor/base16ct/src/lib.rs
@@ -1,3 +1,18 @@
+#![no_std]
+#![cfg_attr(docsrs, feature(doc_auto_cfg))]
+#![doc(
+ html_logo_url = "https://raw.githubusercontent.com/RustCrypto/media/6ee8e381/logo.svg",
+ html_favicon_url = "https://raw.githubusercontent.com/RustCrypto/media/6ee8e381/logo.svg"
+)]
+#![warn(
+ clippy::mod_module_files,
+ clippy::unwrap_used,
+ missing_docs,
+ rust_2018_idioms,
+ unused_lifetimes,
+ unused_qualifications
+)]
+
//! Pure Rust implementation of Base16 ([RFC 4648], a.k.a. hex).
//!
//! Implements lower and upper case Base16 variants without data-dependent branches
@@ -44,15 +59,6 @@
//!
//! [RFC 4648]: https://tools.ietf.org/html/rfc4648
-#![no_std]
-#![cfg_attr(docsrs, feature(doc_cfg))]
-#![warn(missing_docs, rust_2018_idioms)]
-#![doc(
- html_logo_url = "https://raw.githubusercontent.com/RustCrypto/media/6ee8e381/logo.svg",
- html_favicon_url = "https://raw.githubusercontent.com/RustCrypto/media/6ee8e381/logo.svg",
- html_root_url = "https://docs.rs/base16ct/0.1.1"
-)]
-
#[cfg(feature = "alloc")]
#[macro_use]
extern crate alloc;
diff --git a/vendor/base16ct/src/lower.rs b/vendor/base16ct/src/lower.rs
index b6d9f9453..63aa74db3 100644
--- a/vendor/base16ct/src/lower.rs
+++ b/vendor/base16ct/src/lower.rs
@@ -9,7 +9,6 @@ pub fn decode(src: impl AsRef<[u8]>, dst: &mut [u8]) -> Result<&[u8], Error> {
/// Decode a lower Base16 (hex) string into a byte vector.
#[cfg(feature = "alloc")]
-#[cfg_attr(docsrs, doc(cfg(feature = "alloc")))]
pub fn decode_vec(input: impl AsRef<[u8]>) -> Result<Vec<u8>, Error> {
let mut output = vec![0u8; decoded_len(input.as_ref())?];
decode(input, &mut output)?;
@@ -41,7 +40,6 @@ pub fn encode_str<'a>(src: &[u8], dst: &'a mut [u8]) -> Result<&'a str, Error> {
/// # Panics
/// If `input` length is greater than `usize::MAX/2`.
#[cfg(feature = "alloc")]
-#[cfg_attr(docsrs, doc(cfg(feature = "alloc")))]
pub fn encode_string(input: &[u8]) -> String {
let elen = encoded_len(input);
let mut dst = vec![0u8; elen];
diff --git a/vendor/base16ct/src/mixed.rs b/vendor/base16ct/src/mixed.rs
index 50f778d80..0836d3ae4 100644
--- a/vendor/base16ct/src/mixed.rs
+++ b/vendor/base16ct/src/mixed.rs
@@ -9,7 +9,6 @@ pub fn decode(src: impl AsRef<[u8]>, dst: &mut [u8]) -> Result<&[u8], Error> {
/// Decode a mixed Base16 (hex) string into a byte vector.
#[cfg(feature = "alloc")]
-#[cfg_attr(docsrs, doc(cfg(feature = "alloc")))]
pub fn decode_vec(input: impl AsRef<[u8]>) -> Result<Vec<u8>, Error> {
let mut output = vec![0u8; decoded_len(input.as_ref())?];
decode(input, &mut output)?;
diff --git a/vendor/base16ct/src/upper.rs b/vendor/base16ct/src/upper.rs
index 679006e21..a747f297c 100644
--- a/vendor/base16ct/src/upper.rs
+++ b/vendor/base16ct/src/upper.rs
@@ -9,7 +9,6 @@ pub fn decode(src: impl AsRef<[u8]>, dst: &mut [u8]) -> Result<&[u8], Error> {
/// Decode an upper Base16 (hex) string into a byte vector.
#[cfg(feature = "alloc")]
-#[cfg_attr(docsrs, doc(cfg(feature = "alloc")))]
pub fn decode_vec(input: impl AsRef<[u8]>) -> Result<Vec<u8>, Error> {
let mut output = vec![0u8; decoded_len(input.as_ref())?];
decode(input, &mut output)?;
@@ -41,7 +40,6 @@ pub fn encode_str<'a>(src: &[u8], dst: &'a mut [u8]) -> Result<&'a str, Error> {
/// # Panics
/// If `input` length is greater than `usize::MAX/2`.
#[cfg(feature = "alloc")]
-#[cfg_attr(docsrs, doc(cfg(feature = "alloc")))]
pub fn encode_string(input: &[u8]) -> String {
let elen = encoded_len(input);
let mut dst = vec![0u8; elen];