summaryrefslogtreecommitdiffstats
path: root/vendor/block-padding
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--vendor/block-padding/.cargo-checksum.json1
-rw-r--r--vendor/block-padding/Cargo.toml26
-rw-r--r--vendor/block-padding/LICENSE-APACHE201
-rw-r--r--vendor/block-padding/LICENSE-MIT25
-rw-r--r--vendor/block-padding/src/lib.rs323
5 files changed, 576 insertions, 0 deletions
diff --git a/vendor/block-padding/.cargo-checksum.json b/vendor/block-padding/.cargo-checksum.json
new file mode 100644
index 000000000..e80396463
--- /dev/null
+++ b/vendor/block-padding/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"f895c4794f1c00f5f01376dae2b66870d939a01b9a366ee4d177b6b7ad99bd4a","LICENSE-APACHE":"a9040321c3712d8fd0b09cf52b17445de04a23a10165049ae187cd39e5c86be5","LICENSE-MIT":"d5c22aa3118d240e877ad41c5d9fa232f9c77d757d4aac0c2f943afc0a95e0ef","src/lib.rs":"962c90d43c7c2761b3c96fab2713ae357a7a8d2d048e37ce4f3354941ad41b97"},"package":"fa79dedbb091f449f1f39e53edf88d5dbe95f895dae6135a8d7b881fb5af73f5"} \ No newline at end of file
diff --git a/vendor/block-padding/Cargo.toml b/vendor/block-padding/Cargo.toml
new file mode 100644
index 000000000..1b1c849a8
--- /dev/null
+++ b/vendor/block-padding/Cargo.toml
@@ -0,0 +1,26 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "block-padding"
+version = "0.1.5"
+authors = ["RustCrypto Developers"]
+description = "Padding and unpadding of messages divided into blocks."
+documentation = "https://docs.rs/block-padding"
+keywords = ["padding", "pkcs7", "ansix923", "iso7816"]
+categories = ["cryptography", "no-std"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/RustCrypto/utils"
+[dependencies.byte-tools]
+version = "0.3"
+[badges.travis-ci]
+repository = "RustCrypto/utils"
diff --git a/vendor/block-padding/LICENSE-APACHE b/vendor/block-padding/LICENSE-APACHE
new file mode 100644
index 000000000..78173fa2e
--- /dev/null
+++ b/vendor/block-padding/LICENSE-APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+Copyright [yyyy] [name of copyright owner]
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/vendor/block-padding/LICENSE-MIT b/vendor/block-padding/LICENSE-MIT
new file mode 100644
index 000000000..502cee6e8
--- /dev/null
+++ b/vendor/block-padding/LICENSE-MIT
@@ -0,0 +1,25 @@
+Copyright (c) 2018-2019 The RustCrypto Project Developers
+
+Permission is hereby granted, free of charge, to any
+person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without
+limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software
+is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
+TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/vendor/block-padding/src/lib.rs b/vendor/block-padding/src/lib.rs
new file mode 100644
index 000000000..5c4c8c3b6
--- /dev/null
+++ b/vendor/block-padding/src/lib.rs
@@ -0,0 +1,323 @@
+//! Padding and unpadding of messages divided into blocks.
+//!
+//! This crate provides `Padding` trait which provides padding and unpadding
+//! operations. Additionally several common padding schemes are available out
+//! of the box.
+#![no_std]
+#![doc(html_logo_url =
+ "https://raw.githubusercontent.com/RustCrypto/meta/master/logo_small.png")]
+extern crate byte_tools;
+
+use byte_tools::{zero, set};
+
+/// Error for indicating failed padding operation
+#[derive(Clone, Copy, Debug)]
+pub struct PadError;
+
+/// Error for indicating failed unpadding operation
+#[derive(Clone, Copy, Debug)]
+pub struct UnpadError;
+
+/// Trait for padding messages divided into blocks
+pub trait Padding {
+ /// Pads `block` filled with data up to `pos`.
+ ///
+ /// `pos` should be inside of the block and block must not be full, i.e.
+ /// `pos < block.len()` must be true. Otherwise method will return
+ /// `PadError`. Some potentially irreversible padding schemes can allow
+ /// padding of the full block, in this case aforementioned condition is
+ /// relaxed to `pos <= block.len()`.
+ fn pad_block(block: &mut [u8], pos: usize) -> Result<(), PadError>;
+
+ /// Pads message with length `pos` in the provided buffer.
+ ///
+ /// `&buf[..pos]` is perceived as the message, the buffer must contain
+ /// enough leftover space for padding: `block_size - (pos % block_size)`
+ /// extra bytes must be available. Otherwise method will return
+ /// `PadError`.
+ fn pad(buf: &mut [u8], pos: usize, block_size: usize)
+ -> Result<&mut [u8], PadError>
+ {
+ let bs = block_size * (pos / block_size);
+ if buf.len() < bs || buf.len() - bs < block_size { Err(PadError)? }
+ Self::pad_block(&mut buf[bs..bs+block_size], pos - bs)?;
+ Ok(&mut buf[..bs+block_size])
+ }
+
+ /// Unpad given `data` by truncating it according to the used padding.
+ /// In case of the malformed padding will return `UnpadError`
+ fn unpad(data: &[u8]) -> Result<&[u8], UnpadError>;
+}
+
+/// Pad block with zeros.
+///
+/// ```
+/// use block_padding::{ZeroPadding, Padding};
+///
+/// let msg = b"test";
+/// let n = msg.len();
+/// let mut buffer = [0xff; 16];
+/// buffer[..n].copy_from_slice(msg);
+/// let padded_msg = ZeroPadding::pad(&mut buffer, n, 8).unwrap();
+/// assert_eq!(padded_msg, b"test\x00\x00\x00\x00");
+/// assert_eq!(ZeroPadding::unpad(&padded_msg).unwrap(), msg);
+/// ```
+/// ```
+/// # use block_padding::{ZeroPadding, Padding};
+/// # let msg = b"test";
+/// # let n = msg.len();
+/// # let mut buffer = [0xff; 16];
+/// # buffer[..n].copy_from_slice(msg);
+/// let padded_msg = ZeroPadding::pad(&mut buffer, n, 2).unwrap();
+/// assert_eq!(padded_msg, b"test");
+/// assert_eq!(ZeroPadding::unpad(&padded_msg).unwrap(), msg);
+/// ```
+///
+/// Note that zero padding may not be reversible if the original message ends
+/// with one or more zero bytes.
+pub enum ZeroPadding{}
+
+impl Padding for ZeroPadding {
+ fn pad_block(block: &mut [u8], pos: usize) -> Result<(), PadError> {
+ if pos > block.len() { Err(PadError)? }
+ zero(&mut block[pos..]);
+ Ok(())
+ }
+
+ fn pad(buf: &mut [u8], pos: usize, block_size: usize)
+ -> Result<&mut [u8], PadError>
+ {
+ if pos % block_size == 0 {
+ Ok(&mut buf[..pos])
+ } else {
+ let bs = block_size * (pos / block_size);
+ let be = bs + block_size;
+ if buf.len() < be { Err(PadError)? }
+ Self::pad_block(&mut buf[bs..be], pos - bs)?;
+ Ok(&mut buf[..be])
+ }
+ }
+
+ fn unpad(data: &[u8]) -> Result<&[u8], UnpadError> {
+ let mut n = data.len() - 1;
+ while n != 0 {
+ if data[n] != 0 {
+ break;
+ }
+ n -= 1;
+ }
+ Ok(&data[..n+1])
+ }
+}
+
+/// Pad block with bytes with value equal to the number of bytes added.
+///
+/// PKCS#7 described in the [RFC 5652](https://tools.ietf.org/html/rfc5652#section-6.3).
+///
+/// ```
+/// use block_padding::{Pkcs7, Padding};
+///
+/// let msg = b"test";
+/// let n = msg.len();
+/// let mut buffer = [0xff; 8];
+/// buffer[..n].copy_from_slice(msg);
+/// let padded_msg = Pkcs7::pad(&mut buffer, n, 8).unwrap();
+/// assert_eq!(padded_msg, b"test\x04\x04\x04\x04");
+/// assert_eq!(Pkcs7::unpad(&padded_msg).unwrap(), msg);
+/// ```
+/// ```
+/// # use block_padding::{Pkcs7, Padding};
+/// # let msg = b"test";
+/// # let n = msg.len();
+/// # let mut buffer = [0xff; 8];
+/// # buffer[..n].copy_from_slice(msg);
+/// let padded_msg = Pkcs7::pad(&mut buffer, n, 2).unwrap();
+/// assert_eq!(padded_msg, b"test\x02\x02");
+/// assert_eq!(Pkcs7::unpad(&padded_msg).unwrap(), msg);
+/// ```
+/// ```
+/// # use block_padding::{Pkcs7, Padding};
+/// let mut buffer = [0xff; 5];
+/// assert!(Pkcs7::pad(&mut buffer, 4, 2).is_err());
+/// ```
+/// ```
+/// # use block_padding::{Pkcs7, Padding};
+/// # let buffer = [0xff; 16];
+/// assert!(Pkcs7::unpad(&buffer).is_err());
+/// ```
+///
+/// In addition to conditions stated in the `Padding` trait documentation,
+/// `pad_block` will return `PadError` if `block.len() > 255`, and in case of
+/// `pad` if `block_size > 255`.
+pub enum Pkcs7{}
+
+impl Padding for Pkcs7 {
+ fn pad_block(block: &mut [u8], pos: usize) -> Result<(), PadError> {
+ if block.len() > 255 { Err(PadError)? }
+ if pos >= block.len() { Err(PadError)? }
+ let n = block.len() - pos;
+ set(&mut block[pos..], n as u8);
+ Ok(())
+ }
+
+ fn unpad(data: &[u8]) -> Result<&[u8], UnpadError> {
+ if data.is_empty() { Err(UnpadError)? }
+ let l = data.len();
+ let n = data[l-1];
+ if n == 0 || n as usize > l { Err(UnpadError)? }
+ for v in &data[l-n as usize..l-1] {
+ if *v != n { Err(UnpadError)? }
+ }
+ Ok(&data[..l - n as usize])
+ }
+}
+
+/// Pad block with zeros except the last byte which will be set to the number
+/// bytes.
+///
+/// ```
+/// use block_padding::{AnsiX923, Padding};
+///
+/// let msg = b"test";
+/// let n = msg.len();
+/// let mut buffer = [0xff; 16];
+/// buffer[..n].copy_from_slice(msg);
+/// let padded_msg = AnsiX923::pad(&mut buffer, n, 8).unwrap();
+/// assert_eq!(padded_msg, b"test\x00\x00\x00\x04");
+/// assert_eq!(AnsiX923::unpad(&padded_msg).unwrap(), msg);
+/// ```
+/// ```
+/// # use block_padding::{AnsiX923, Padding};
+/// # let msg = b"test";
+/// # let n = msg.len();
+/// # let mut buffer = [0xff; 16];
+/// # buffer[..n].copy_from_slice(msg);
+/// let padded_msg = AnsiX923::pad(&mut buffer, n, 2).unwrap();
+/// assert_eq!(padded_msg, b"test\x00\x02");
+/// assert_eq!(AnsiX923::unpad(&padded_msg).unwrap(), msg);
+/// ```
+/// ```
+/// # use block_padding::{AnsiX923, Padding};
+/// # let buffer = [0xff; 16];
+/// assert!(AnsiX923::unpad(&buffer).is_err());
+/// ```
+///
+/// In addition to conditions stated in the `Padding` trait documentation,
+/// `pad_block` will return `PadError` if `block.len() > 255`, and in case of
+/// `pad` if `block_size > 255`.
+pub enum AnsiX923{}
+
+impl Padding for AnsiX923 {
+ fn pad_block(block: &mut [u8], pos: usize) -> Result<(), PadError>{
+ if block.len() > 255 { Err(PadError)? }
+ if pos >= block.len() { Err(PadError)? }
+ let bs = block.len();
+ zero(&mut block[pos..bs-1]);
+ block[bs-1] = (bs - pos) as u8;
+ Ok(())
+ }
+
+ fn unpad(data: &[u8]) -> Result<&[u8], UnpadError> {
+ if data.is_empty() { Err(UnpadError)? }
+ let l = data.len();
+ let n = data[l-1] as usize;
+ if n == 0 || n > l {
+ return Err(UnpadError)
+ }
+ for v in &data[l-n..l-1] {
+ if *v != 0 { Err(UnpadError)? }
+ }
+ Ok(&data[..l-n])
+ }
+}
+
+/// Pad block with byte sequence `\x80 00...00 00`.
+///
+/// ```
+/// use block_padding::{Iso7816, Padding};
+///
+/// let msg = b"test";
+/// let n = msg.len();
+/// let mut buffer = [0xff; 16];
+/// buffer[..n].copy_from_slice(msg);
+/// let padded_msg = Iso7816::pad(&mut buffer, n, 8).unwrap();
+/// assert_eq!(padded_msg, b"test\x80\x00\x00\x00");
+/// assert_eq!(Iso7816::unpad(&padded_msg).unwrap(), msg);
+/// ```
+/// ```
+/// # use block_padding::{Iso7816, Padding};
+/// # let msg = b"test";
+/// # let n = msg.len();
+/// # let mut buffer = [0xff; 16];
+/// # buffer[..n].copy_from_slice(msg);
+/// let padded_msg = Iso7816::pad(&mut buffer, n, 2).unwrap();
+/// assert_eq!(padded_msg, b"test\x80\x00");
+/// assert_eq!(Iso7816::unpad(&padded_msg).unwrap(), msg);
+/// ```
+pub enum Iso7816{}
+
+impl Padding for Iso7816 {
+ fn pad_block(block: &mut [u8], pos: usize) -> Result<(), PadError> {
+ if pos >= block.len() { Err(PadError)? }
+ block[pos] = 0x80;
+ zero(&mut block[pos+1..]);
+ Ok(())
+ }
+
+ fn unpad(data: &[u8]) -> Result<&[u8], UnpadError> {
+ if data.is_empty() { Err(UnpadError)? }
+ let mut n = data.len() - 1;
+ while n != 0 {
+ if data[n] != 0 { break; }
+ n -= 1;
+ }
+ if data[n] != 0x80 { Err(UnpadError)? }
+ Ok(&data[..n])
+ }
+}
+
+/// Don't pad the data. Useful for key wrapping. Padding will fail if the data cannot be
+/// fitted into blocks without padding.
+///
+/// ```
+/// use block_padding::{NoPadding, Padding};
+///
+/// let msg = b"test";
+/// let n = msg.len();
+/// let mut buffer = [0xff; 16];
+/// buffer[..n].copy_from_slice(msg);
+/// let padded_msg = NoPadding::pad(&mut buffer, n, 4).unwrap();
+/// assert_eq!(padded_msg, b"test");
+/// assert_eq!(NoPadding::unpad(&padded_msg).unwrap(), msg);
+/// ```
+/// ```
+/// # use block_padding::{NoPadding, Padding};
+/// # let msg = b"test";
+/// # let n = msg.len();
+/// # let mut buffer = [0xff; 16];
+/// # buffer[..n].copy_from_slice(msg);
+/// let padded_msg = NoPadding::pad(&mut buffer, n, 2).unwrap();
+/// assert_eq!(padded_msg, b"test");
+/// assert_eq!(NoPadding::unpad(&padded_msg).unwrap(), msg);
+/// ```
+pub enum NoPadding {}
+
+impl Padding for NoPadding {
+ fn pad_block(block: &mut [u8], pos: usize) -> Result<(), PadError> {
+ if pos % block.len() != 0 {
+ Err(PadError)?
+ }
+ Ok(())
+ }
+
+ fn pad(buf: &mut [u8], pos: usize, block_size: usize) -> Result<&mut [u8], PadError> {
+ if pos % block_size != 0 {
+ Err(PadError)?
+ }
+ Ok(&mut buf[..pos])
+ }
+
+ fn unpad(data: &[u8]) -> Result<&[u8], UnpadError> {
+ Ok(data)
+ }
+}