summaryrefslogtreecommitdiffstats
path: root/vendor/bytecount/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/bytecount/Cargo.toml')
-rw-r--r--vendor/bytecount/Cargo.toml53
1 files changed, 53 insertions, 0 deletions
diff --git a/vendor/bytecount/Cargo.toml b/vendor/bytecount/Cargo.toml
new file mode 100644
index 000000000..e3571c5c1
--- /dev/null
+++ b/vendor/bytecount/Cargo.toml
@@ -0,0 +1,53 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "bytecount"
+version = "0.6.2"
+authors = ["Andre Bogus <bogusandre@gmail.de>", "Joshua Landau <joshua@landau.ws>"]
+exclude = ["/.travis.yml", "/appveyor.yml"]
+description = "count occurrences of a given byte, or the number of UTF-8 code points, in a byte slice, fast"
+readme = "README.md"
+categories = ["algorithms", "no-std"]
+license = "Apache-2.0/MIT"
+repository = "https://github.com/llogiq/bytecount"
+
+[lib]
+bench = false
+
+[[bench]]
+name = "bench"
+harness = false
+[dependencies.packed_simd]
+version = "0.3.4"
+optional = true
+package = "packed_simd_2"
+[dev-dependencies.criterion]
+version = "0.3"
+default-features = false
+
+[dev-dependencies.quickcheck]
+version = "0.9"
+
+[dev-dependencies.rand]
+version = "0.7"
+
+[features]
+generic-simd = ["packed_simd"]
+html_report = []
+runtime-dispatch-simd = []
+[badges.appveyor]
+repository = "llogiq/bytecount"
+
+[badges.travis-ci]
+repository = "llogiq/bytecount"