summaryrefslogtreecommitdiffstats
path: root/vendor/bytes/README.md
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/bytes/README.md')
-rw-r--r--vendor/bytes/README.md47
1 files changed, 47 insertions, 0 deletions
diff --git a/vendor/bytes/README.md b/vendor/bytes/README.md
new file mode 100644
index 000000000..468485d12
--- /dev/null
+++ b/vendor/bytes/README.md
@@ -0,0 +1,47 @@
+# Bytes
+
+A utility library for working with bytes.
+
+[![Crates.io][crates-badge]][crates-url]
+[![Build Status][ci-badge]][ci-url]
+
+[crates-badge]: https://img.shields.io/crates/v/bytes.svg
+[crates-url]: https://crates.io/crates/bytes
+[ci-badge]: https://github.com/tokio-rs/bytes/workflows/CI/badge.svg
+[ci-url]: https://github.com/tokio-rs/bytes/actions
+
+[Documentation](https://docs.rs/bytes)
+
+## Usage
+
+To use `bytes`, first add this to your `Cargo.toml`:
+
+```toml
+[dependencies]
+bytes = "1"
+```
+
+Next, add this to your crate:
+
+```rust
+use bytes::{Bytes, BytesMut, Buf, BufMut};
+```
+
+## Serde support
+
+Serde support is optional and disabled by default. To enable use the feature `serde`.
+
+```toml
+[dependencies]
+bytes = { version = "1", features = ["serde"] }
+```
+
+## License
+
+This project is licensed under the [MIT license](LICENSE).
+
+### Contribution
+
+Unless you explicitly state otherwise, any contribution intentionally submitted
+for inclusion in `bytes` by you, shall be licensed as MIT, without any additional
+terms or conditions.