summaryrefslogtreecommitdiffstats
path: root/vendor/chalk-derive-0.87.0/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/chalk-derive-0.87.0/Cargo.toml')
-rw-r--r--vendor/chalk-derive-0.87.0/Cargo.toml44
1 files changed, 44 insertions, 0 deletions
diff --git a/vendor/chalk-derive-0.87.0/Cargo.toml b/vendor/chalk-derive-0.87.0/Cargo.toml
new file mode 100644
index 000000000..45bade326
--- /dev/null
+++ b/vendor/chalk-derive-0.87.0/Cargo.toml
@@ -0,0 +1,44 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "chalk-derive"
+version = "0.87.0"
+authors = [
+ "Rust Compiler Team",
+ "Chalk developers",
+]
+description = "A helper crate for use by chalk crates for `derive` macros."
+readme = "README.md"
+keywords = [
+ "compiler",
+ "traits",
+ "prolog",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-lang/chalk"
+
+[lib]
+proc-macro = true
+
+[dependencies.proc-macro2]
+version = "1.0"
+
+[dependencies.quote]
+version = "1.0"
+
+[dependencies.syn]
+version = "1.0"
+features = ["full"]
+
+[dependencies.synstructure]
+version = "0.12.5"