summaryrefslogtreecommitdiffstats
path: root/vendor/chalk-engine/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/chalk-engine/Cargo.toml')
-rw-r--r--vendor/chalk-engine/Cargo.toml40
1 files changed, 40 insertions, 0 deletions
diff --git a/vendor/chalk-engine/Cargo.toml b/vendor/chalk-engine/Cargo.toml
new file mode 100644
index 000000000..413af5387
--- /dev/null
+++ b/vendor/chalk-engine/Cargo.toml
@@ -0,0 +1,40 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "chalk-engine"
+version = "0.80.0"
+authors = ["Rust Compiler Team", "Chalk developers"]
+description = "Core trait engine from Chalk project"
+readme = "README.md"
+keywords = ["compiler", "traits", "prolog"]
+license = "Apache-2.0/MIT"
+repository = "https://github.com/rust-lang/chalk"
+[dependencies.chalk-derive]
+version = "=0.80.0"
+
+[dependencies.chalk-ir]
+version = "=0.80.0"
+
+[dependencies.chalk-solve]
+version = "=0.80.0"
+
+[dependencies.rustc-hash]
+version = "1.1.0"
+
+[dependencies.tracing]
+version = "0.1"
+
+[dev-dependencies]
+
+[features]
+default = []