summaryrefslogtreecommitdiffstats
path: root/vendor/chalk-solve/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/chalk-solve/Cargo.toml')
-rw-r--r--vendor/chalk-solve/Cargo.toml70
1 files changed, 70 insertions, 0 deletions
diff --git a/vendor/chalk-solve/Cargo.toml b/vendor/chalk-solve/Cargo.toml
new file mode 100644
index 000000000..b57214aa8
--- /dev/null
+++ b/vendor/chalk-solve/Cargo.toml
@@ -0,0 +1,70 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "chalk-solve"
+version = "0.87.0"
+authors = [
+ "Rust Compiler Team",
+ "Chalk developers",
+]
+description = "Combines the chalk-engine with chalk-ir"
+readme = "README.md"
+keywords = [
+ "compiler",
+ "traits",
+ "prolog",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-lang/chalk"
+
+[dependencies.chalk-derive]
+version = "=0.87.0"
+
+[dependencies.chalk-ir]
+version = "=0.87.0"
+
+[dependencies.ena]
+version = "0.14.0"
+
+[dependencies.indexmap]
+version = "1.8.0"
+
+[dependencies.itertools]
+version = "0.10.0"
+
+[dependencies.petgraph]
+version = "0.5.1"
+
+[dependencies.rustc-hash]
+version = "1.1.0"
+
+[dependencies.tracing]
+version = "0.1"
+
+[dependencies.tracing-subscriber]
+version = "0.3"
+features = ["env-filter"]
+optional = true
+
+[dependencies.tracing-tree]
+version = "0.2"
+optional = true
+
+[dev-dependencies]
+
+[features]
+default = ["tracing-full"]
+tracing-full = [
+ "tracing-subscriber",
+ "tracing-tree",
+]