summaryrefslogtreecommitdiffstats
path: root/vendor/chrono/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/chrono/Makefile')
-rw-r--r--vendor/chrono/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/vendor/chrono/Makefile b/vendor/chrono/Makefile
new file mode 100644
index 000000000..63aef15ac
--- /dev/null
+++ b/vendor/chrono/Makefile
@@ -0,0 +1,26 @@
+# this Makefile is mostly for the packaging convenience.
+# casual users should use `cargo` to retrieve the appropriate version of Chrono.
+
+CHANNEL=stable
+
+.PHONY: all
+all:
+ @echo 'Try `cargo build` instead.'
+
+.PHONY: authors
+authors:
+ echo 'Chrono is mainly written by Kang Seonghoon <public+rust@mearie.org>,' > AUTHORS.txt
+ echo 'and also the following people (in ascending order):' >> AUTHORS.txt
+ echo >> AUTHORS.txt
+ git log --format='%aN <%aE>' | grep -v 'Kang Seonghoon' | sort -u >> AUTHORS.txt
+
+.PHONY: readme README.md
+readme: README.md
+
+.PHONY: test
+test:
+ CHANNEL=$(CHANNEL) ./ci/travis.sh
+
+.PHONY: doc
+doc: authors readme
+ cargo doc --features 'serde rustc-serialize bincode'