summaryrefslogtreecommitdiffstats
path: root/vendor/clap-2.34.0/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/clap-2.34.0/Cargo.toml')
-rw-r--r--vendor/clap-2.34.0/Cargo.toml132
1 files changed, 0 insertions, 132 deletions
diff --git a/vendor/clap-2.34.0/Cargo.toml b/vendor/clap-2.34.0/Cargo.toml
deleted file mode 100644
index bb6bf0932..000000000
--- a/vendor/clap-2.34.0/Cargo.toml
+++ /dev/null
@@ -1,132 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
-#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
-
-[package]
-edition = "2018"
-name = "clap"
-version = "2.34.0"
-authors = ["Kevin K. <kbknapp@gmail.com>"]
-exclude = ["examples/*", "clap-test/*", "tests/*", "benches/*", "*.png", "clap-perf/*", "*.dot"]
-description = "A simple to use, efficient, and full-featured Command Line Argument Parser\n"
-homepage = "https://clap.rs/"
-documentation = "https://docs.rs/clap/"
-readme = "README.md"
-keywords = ["argument", "cli", "arg", "parser", "parse"]
-categories = ["command-line-interface"]
-license = "MIT"
-repository = "https://github.com/clap-rs/clap"
-[package.metadata.docs.rs]
-features = ["doc"]
-[profile.bench]
-opt-level = 3
-lto = true
-codegen-units = 1
-debug = false
-debug-assertions = false
-rpath = false
-
-[profile.dev]
-opt-level = 0
-lto = false
-codegen-units = 4
-debug = true
-debug-assertions = true
-rpath = false
-
-[profile.release]
-opt-level = 3
-lto = true
-codegen-units = 1
-debug = false
-debug-assertions = false
-rpath = false
-
-[profile.test]
-opt-level = 1
-lto = false
-codegen-units = 4
-debug = true
-debug-assertions = true
-rpath = false
-[dependencies.atty]
-version = "0.2.2"
-optional = true
-
-[dependencies.bitflags]
-version = "1.0"
-
-[dependencies.clippy]
-version = "~0.0.166"
-optional = true
-
-[dependencies.strsim]
-version = "0.8"
-optional = true
-
-[dependencies.term_size]
-version = "0.3.0"
-optional = true
-
-[dependencies.textwrap]
-version = "0.11.0"
-
-[dependencies.unicode-width]
-version = "0.1.4"
-
-[dependencies.vec_map]
-version = "0.8"
-optional = true
-
-[dependencies.yaml-rust]
-version = "0.3.5"
-optional = true
-[dev-dependencies.lazy_static]
-version = "1.3"
-
-[dev-dependencies.regex]
-version = "1"
-
-[dev-dependencies.version-sync]
-version = "0.8"
-
-[features]
-color = ["ansi_term", "atty"]
-debug = []
-default = ["suggestions", "color", "vec_map"]
-doc = ["yaml"]
-nightly = []
-no_cargo = []
-suggestions = ["strsim"]
-unstable = []
-wrap_help = ["term_size", "textwrap/term_size"]
-yaml = ["yaml-rust"]
-[target."cfg(not(windows))".dependencies.ansi_term]
-version = "0.12"
-optional = true
-[badges.appveyor]
-repository = "clap-rs/clap"
-
-[badges.coveralls]
-branch = "master"
-repository = "clap-rs/clap"
-
-[badges.is-it-maintained-issue-resolution]
-repository = "clap-rs/clap"
-
-[badges.is-it-maintained-open-issues]
-repository = "clap-rs/clap"
-
-[badges.maintenance]
-status = "actively-developed"
-
-[badges.travis-ci]
-repository = "clap-rs/clap"