summaryrefslogtreecommitdiffstats
path: root/vendor/clap-3.2.20/examples/cargo-example-derive.md
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/clap-3.2.20/examples/cargo-example-derive.md')
-rw-r--r--vendor/clap-3.2.20/examples/cargo-example-derive.md43
1 files changed, 43 insertions, 0 deletions
diff --git a/vendor/clap-3.2.20/examples/cargo-example-derive.md b/vendor/clap-3.2.20/examples/cargo-example-derive.md
new file mode 100644
index 000000000..2c7a11b88
--- /dev/null
+++ b/vendor/clap-3.2.20/examples/cargo-example-derive.md
@@ -0,0 +1,43 @@
+For more on creating a custom subcommand, see [the cargo
+book](https://doc.rust-lang.org/cargo/reference/external-tools.html#custom-subcommands).
+The crate [`clap-cargo`](https://github.com/crate-ci/clap-cargo) can help in
+mimicking cargo's interface.
+
+The help looks like:
+```console
+$ cargo-example-derive --help
+cargo
+
+USAGE:
+ cargo <SUBCOMMAND>
+
+OPTIONS:
+ -h, --help Print help information
+
+SUBCOMMANDS:
+ example-derive A simple to use, efficient, and full-featured Command Line Argument Parser
+ help Print this message or the help of the given subcommand(s)
+
+$ cargo-example-derive example-derive --help
+cargo-example-derive [..]
+A simple to use, efficient, and full-featured Command Line Argument Parser
+
+USAGE:
+ cargo example-derive [OPTIONS]
+
+OPTIONS:
+ -h, --help Print help information
+ --manifest-path <MANIFEST_PATH>
+ -V, --version Print version information
+
+```
+
+Then to directly invoke the command, run:
+```console
+$ cargo-example-derive example-derive
+None
+
+$ cargo-example-derive example-derive --manifest-path Cargo.toml
+Some("Cargo.toml")
+
+```