summaryrefslogtreecommitdiffstats
path: root/vendor/clap/examples/cargo-example.md
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/clap/examples/cargo-example.md')
-rw-r--r--vendor/clap/examples/cargo-example.md43
1 files changed, 0 insertions, 43 deletions
diff --git a/vendor/clap/examples/cargo-example.md b/vendor/clap/examples/cargo-example.md
deleted file mode 100644
index 6fb6a3c4d..000000000
--- a/vendor/clap/examples/cargo-example.md
+++ /dev/null
@@ -1,43 +0,0 @@
-For more on creating a custom subcommand, see [the cargo
-book](https://doc.rust-lang.org/cargo/reference/external-tools.html#custom-subcommands).
-The crate [`clap-cargo`](https://github.com/crate-ci/clap-cargo) can help in
-mimicking cargo's interface.
-
-The help looks like:
-```console
-$ cargo-example --help
-cargo
-
-USAGE:
- cargo <SUBCOMMAND>
-
-OPTIONS:
- -h, --help Print help information
-
-SUBCOMMANDS:
- example A simple to use, efficient, and full-featured Command Line Argument Parser
- help Print this message or the help of the given subcommand(s)
-
-$ cargo-example example --help
-cargo-example [..]
-A simple to use, efficient, and full-featured Command Line Argument Parser
-
-USAGE:
- cargo example [OPTIONS]
-
-OPTIONS:
- -h, --help Print help information
- --manifest-path <PATH>
- -V, --version Print version information
-
-```
-
-Then to directly invoke the command, run:
-```console
-$ cargo-example example
-None
-
-$ cargo-example example --manifest-path Cargo.toml
-Some("Cargo.toml")
-
-```