summaryrefslogtreecommitdiffstats
path: root/vendor/clap/examples/tutorial_builder/02_crate.rs
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/clap/examples/tutorial_builder/02_crate.rs')
-rw-r--r--vendor/clap/examples/tutorial_builder/02_crate.rs18
1 files changed, 18 insertions, 0 deletions
diff --git a/vendor/clap/examples/tutorial_builder/02_crate.rs b/vendor/clap/examples/tutorial_builder/02_crate.rs
new file mode 100644
index 000000000..ad6bb4713
--- /dev/null
+++ b/vendor/clap/examples/tutorial_builder/02_crate.rs
@@ -0,0 +1,18 @@
+use clap::{arg, command};
+
+fn main() {
+ // requires `cargo` feature, reading name, version, author, and description from `Cargo.toml`
+ let matches = command!()
+ .arg(arg!(--two <VALUE>).required(true))
+ .arg(arg!(--one <VALUE>).required(true))
+ .get_matches();
+
+ println!(
+ "two: {:?}",
+ matches.get_one::<String>("two").expect("required")
+ );
+ println!(
+ "one: {:?}",
+ matches.get_one::<String>("one").expect("required")
+ );
+}