summaryrefslogtreecommitdiffstats
path: root/vendor/clap/examples/tutorial_derive/02_crate.rs
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/clap/examples/tutorial_derive/02_crate.rs')
-rw-r--r--vendor/clap/examples/tutorial_derive/02_crate.rs17
1 files changed, 17 insertions, 0 deletions
diff --git a/vendor/clap/examples/tutorial_derive/02_crate.rs b/vendor/clap/examples/tutorial_derive/02_crate.rs
new file mode 100644
index 000000000..33a7a4ee0
--- /dev/null
+++ b/vendor/clap/examples/tutorial_derive/02_crate.rs
@@ -0,0 +1,17 @@
+use clap::Parser;
+
+#[derive(Parser)]
+#[command(author, version, about, long_about = None)] // Read from `Cargo.toml`
+struct Cli {
+ #[arg(long)]
+ two: String,
+ #[arg(long)]
+ one: String,
+}
+
+fn main() {
+ let cli = Cli::parse();
+
+ println!("two: {:?}", cli.two);
+ println!("one: {:?}", cli.one);
+}