summaryrefslogtreecommitdiffstats
path: root/vendor/clap_derive-3.2.18/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/clap_derive-3.2.18/Cargo.toml')
-rw-r--r--vendor/clap_derive-3.2.18/Cargo.toml83
1 files changed, 83 insertions, 0 deletions
diff --git a/vendor/clap_derive-3.2.18/Cargo.toml b/vendor/clap_derive-3.2.18/Cargo.toml
new file mode 100644
index 000000000..f74476e68
--- /dev/null
+++ b/vendor/clap_derive-3.2.18/Cargo.toml
@@ -0,0 +1,83 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.56.1"
+name = "clap_derive"
+version = "3.2.18"
+include = [
+ "build.rs",
+ "src/**/*",
+ "Cargo.toml",
+ "LICENSE*",
+ "README.md",
+ "benches/**/*",
+ "examples/**/*",
+]
+description = "Parse command line argument by defining a struct, derive crate."
+readme = "README.md"
+keywords = [
+ "clap",
+ "cli",
+ "parse",
+ "derive",
+ "proc_macro",
+]
+categories = [
+ "command-line-interface",
+ "development-tools::procedural-macro-helpers",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/clap-rs/clap/tree/master/clap_derive"
+resolver = "2"
+
+[package.metadata.docs.rs]
+targets = ["x86_64-unknown-linux-gnu"]
+
+[package.metadata.release]
+shared-version = true
+dependent-version = "upgrade"
+tag-name = "v{{version}}"
+
+[[package.metadata.release.pre-release-replacements]]
+file = "README.md"
+search = "github.com/clap-rs/clap/blob/[^/]+/"
+replace = "github.com/clap-rs/clap/blob/{{tag_name}}/"
+exactly = 2
+prerelease = true
+
+[lib]
+bench = false
+proc-macro = true
+
+[dependencies.heck]
+version = "0.4.0"
+
+[dependencies.proc-macro-error]
+version = "1"
+
+[dependencies.proc-macro2]
+version = "1.0.28"
+
+[dependencies.quote]
+version = "1.0.9"
+
+[dependencies.syn]
+version = "1.0.74"
+features = ["full"]
+
+[features]
+debug = []
+default = []
+deprecated = []
+raw-deprecated = ["deprecated"]
+unstable-v4 = ["deprecated"]