summaryrefslogtreecommitdiffstats
path: root/vendor/cmake/README.md
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/cmake/README.md')
-rw-r--r--vendor/cmake/README.md32
1 files changed, 32 insertions, 0 deletions
diff --git a/vendor/cmake/README.md b/vendor/cmake/README.md
new file mode 100644
index 000000000..7ef49ca02
--- /dev/null
+++ b/vendor/cmake/README.md
@@ -0,0 +1,32 @@
+# cmake
+
+[Documentation](https://docs.rs/cmake)
+
+A build dependency for running the `cmake` build tool to compile a native
+library.
+
+```toml
+# Cargo.toml
+[build-dependencies]
+cmake = "0.1"
+```
+
+The CMake executable is assumed to be `cmake` unless the `CMAKE`
+environmental variable is set.
+
+# License
+
+This project is licensed under either of
+
+ * Apache License, Version 2.0, ([LICENSE-APACHE](LICENSE-APACHE) or
+ http://www.apache.org/licenses/LICENSE-2.0)
+ * MIT license ([LICENSE-MIT](LICENSE-MIT) or
+ http://opensource.org/licenses/MIT)
+
+at your option.
+
+### Contribution
+
+Unless you explicitly state otherwise, any contribution intentionally submitted
+for inclusion in cmake by you, as defined in the Apache-2.0 license, shall be
+dual licensed as above, without any additional terms or conditions.