summaryrefslogtreecommitdiffstats
path: root/vendor/compiler_builtins/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/compiler_builtins/Cargo.toml')
-rw-r--r--vendor/compiler_builtins/Cargo.toml73
1 files changed, 73 insertions, 0 deletions
diff --git a/vendor/compiler_builtins/Cargo.toml b/vendor/compiler_builtins/Cargo.toml
new file mode 100644
index 000000000..765e99f94
--- /dev/null
+++ b/vendor/compiler_builtins/Cargo.toml
@@ -0,0 +1,73 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "compiler_builtins"
+version = "0.1.73"
+authors = ["Jorge Aparicio <japaricious@gmail.com>"]
+links = "compiler-rt"
+include = [
+ "/Cargo.toml",
+ "/build.rs",
+ "/src/*",
+ "/examples/*",
+ "/LICENSE.txt",
+ "/README.md",
+ "/compiler-rt/*",
+ "/libm/src/math/*",
+]
+description = """
+Compiler intrinsics used by the Rust compiler. Also available for other targets
+if necessary!
+"""
+homepage = "https://github.com/rust-lang/compiler-builtins"
+documentation = "https://docs.rs/compiler_builtins"
+readme = "README.md"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/rust-lang/compiler-builtins"
+
+[profile.dev]
+panic = "abort"
+
+[profile.release]
+panic = "abort"
+
+[lib]
+test = false
+
+[[example]]
+name = "intrinsics"
+required-features = ["compiler-builtins"]
+
+[dependencies.core]
+version = "1.0.0"
+optional = true
+package = "rustc-std-workspace-core"
+
+[dev-dependencies]
+
+[build-dependencies.cc]
+version = "1.0"
+optional = true
+
+[features]
+c = ["cc"]
+compiler-builtins = []
+default = ["compiler-builtins"]
+mangled-names = []
+mem = []
+no-asm = []
+no-lang-items = []
+public-test-deps = []
+rustc-dep-of-std = [
+ "compiler-builtins",
+ "core",
+]