summaryrefslogtreecommitdiffstats
path: root/vendor/core-foundation/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/core-foundation/Cargo.toml')
-rw-r--r--vendor/core-foundation/Cargo.toml41
1 files changed, 41 insertions, 0 deletions
diff --git a/vendor/core-foundation/Cargo.toml b/vendor/core-foundation/Cargo.toml
new file mode 100644
index 000000000..372964096
--- /dev/null
+++ b/vendor/core-foundation/Cargo.toml
@@ -0,0 +1,41 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "core-foundation"
+version = "0.9.0"
+authors = ["The Servo Project Developers"]
+description = "Bindings to Core Foundation for macOS"
+homepage = "https://github.com/servo/core-foundation-rs"
+keywords = ["macos", "framework", "objc"]
+categories = ["os::macos-apis"]
+license = "MIT / Apache-2.0"
+repository = "https://github.com/servo/core-foundation-rs"
+[dependencies.chrono]
+version = "0.4"
+optional = true
+
+[dependencies.core-foundation-sys]
+version = "0.8.0"
+
+[dependencies.libc]
+version = "0.2"
+
+[dependencies.uuid]
+version = "0.5"
+optional = true
+
+[features]
+mac_os_10_7_support = ["core-foundation-sys/mac_os_10_7_support"]
+mac_os_10_8_features = ["core-foundation-sys/mac_os_10_8_features"]
+with-chrono = ["chrono"]
+with-uuid = ["uuid"]