summaryrefslogtreecommitdiffstats
path: root/vendor/countme/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/countme/Cargo.toml')
-rw-r--r--vendor/countme/Cargo.toml48
1 files changed, 48 insertions, 0 deletions
diff --git a/vendor/countme/Cargo.toml b/vendor/countme/Cargo.toml
new file mode 100644
index 000000000..675dea03a
--- /dev/null
+++ b/vendor/countme/Cargo.toml
@@ -0,0 +1,48 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "countme"
+version = "3.0.1"
+authors = ["Aleksey Kladov <aleksey.kladov@gmail.com>"]
+exclude = [".github/", "bors.toml", "rustfmt.toml"]
+description = "Counts the number of live instances of types"
+categories = ["development-tools::profiling"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/matklad/countme"
+
+[[example]]
+name = "print_at_exit"
+required-features = ["print_at_exit"]
+
+[[example]]
+name = "bench"
+required-features = ["enable"]
+
+[[example]]
+name = "bench_single_thread"
+required-features = ["enable"]
+[dependencies.dashmap]
+version = "5.0"
+optional = true
+
+[dependencies.once_cell]
+version = "1.5"
+optional = true
+
+[dependencies.rustc-hash]
+version = "1.1"
+optional = true
+
+[features]
+enable = ["dashmap", "once_cell", "rustc-hash"]
+print_at_exit = ["enable"]