summaryrefslogtreecommitdiffstats
path: root/vendor/crossbeam-channel/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/crossbeam-channel/Cargo.toml')
-rw-r--r--vendor/crossbeam-channel/Cargo.toml54
1 files changed, 54 insertions, 0 deletions
diff --git a/vendor/crossbeam-channel/Cargo.toml b/vendor/crossbeam-channel/Cargo.toml
new file mode 100644
index 000000000..c02f8595c
--- /dev/null
+++ b/vendor/crossbeam-channel/Cargo.toml
@@ -0,0 +1,54 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.36"
+name = "crossbeam-channel"
+version = "0.5.5"
+description = "Multi-producer multi-consumer channels for message passing"
+homepage = "https://github.com/crossbeam-rs/crossbeam/tree/master/crossbeam-channel"
+readme = "README.md"
+keywords = [
+ "channel",
+ "mpmc",
+ "select",
+ "golang",
+ "message",
+]
+categories = [
+ "algorithms",
+ "concurrency",
+ "data-structures",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/crossbeam-rs/crossbeam"
+
+[dependencies.cfg-if]
+version = "1"
+
+[dependencies.crossbeam-utils]
+version = "0.8"
+optional = true
+default-features = false
+
+[dev-dependencies.num_cpus]
+version = "1.13.0"
+
+[dev-dependencies.rand]
+version = "0.8"
+
+[dev-dependencies.signal-hook]
+version = "0.3"
+
+[features]
+default = ["std"]
+std = ["crossbeam-utils/std"]